Bug 209336 - [MAINTAINER UPDATE]: sysutils/slurm-wlm upgrade to 15.08.11
Summary: [MAINTAINER UPDATE]: sysutils/slurm-wlm upgrade to 15.08.11
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-06 18:41 UTC by Joseph Mingrone
Modified: 2016-05-14 01:49 UTC (History)
1 user (show)

See Also:


Attachments
svn patch to upgrade sysutils/slurm-wlm to 15.08.11 (820 bytes, patch)
2016-05-06 18:41 UTC, Joseph Mingrone
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Kurt Jaeger freebsd_committer 2016-05-07 09:38:28 UTC
Testbuilds are fine, building on a populated host fails with
Comment 2 Joseph Mingrone freebsd_committer 2016-05-07 10:36:45 UTC
Did your comment get truncated?  I don't see the build error.
Comment 3 Kurt Jaeger freebsd_committer 2016-05-07 11:10:48 UTC
... see

http://people.freebsd.org/~pi/logs/slurm-build.txt
Comment 4 Joseph Mingrone freebsd_committer 2016-05-07 22:02:08 UTC
Slurm will install files depending on what is installed in the host environment.  To make matters worse, there seems to be some "dynamic" plist entries that can't be turned off with a configure flag.

I guess the IMPI files are being installed because you have sysutils/freeipmi installed, but I'm still at a loss for the others.  Can you try this patch http://ftfl.ca/misc/slurm-wlm-15.08.11.diff and show me the list of installed packages and the configure log?
Comment 5 Kurt Jaeger freebsd_committer 2016-05-08 03:13:37 UTC
(In reply to Joseph Mingrone from comment #4)
After I deleted freeipmi on that host, there are less issues, but still:

===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: lib/slurm/burst_buffer_cray.a
Error: Orphaned: lib/slurm/burst_buffer_cray.so
Error: Orphaned: lib/slurm/jobcomp_elasticsearch.a
Error: Orphaned: lib/slurm/jobcomp_elasticsearch.so
Error: Orphaned: lib/slurm/power_cray.a
Error: Orphaned: lib/slurm/power_cray.so
Comment 6 Joseph Mingrone freebsd_committer 2016-05-08 03:16:20 UTC
The updated patch should take care of the IPMP files.  For the others I'm going through the output of your configure output trying to match your environment on a FreeBSD 11 host, but I still can't reproduce the problem.  Can you send me a list of your installed packages?
Comment 7 Kurt Jaeger freebsd_committer 2016-05-08 09:37:37 UTC
I'll commit, as it builds in poudriere. May I ask you to try to ask upstream to provide configure options to disable things that configure accidentially picks up ?
Comment 8 commit-hook freebsd_committer 2016-05-08 09:40:31 UTC
A commit references this bug:

Author: pi
Date: Sun May  8 09:39:33 UTC 2016
New revision: 414795
URL: https://svnweb.freebsd.org/changeset/ports/414795

Log:
  sysutils/slurm-wlm: 15.08.10 -> 15.08.11

  - bug-fixes only

  PR:		209336
  Submitted by:	Joseph Mingrone <jrm@ftfl.ca> (maintainer)

Changes:
  head/sysutils/slurm-wlm/Makefile
  head/sysutils/slurm-wlm/distinfo
Comment 9 Kurt Jaeger freebsd_committer 2016-05-08 09:41:48 UTC
Committed, thanks!
Comment 10 Joseph Mingrone freebsd_committer 2016-05-14 01:49:24 UTC
FYI, I haven't forgotten about the issue.

http://thread.gmane.org/gmane.comp.distributed.slurm.devel/9969