Bug 209460 - x11/xorg: xorg-7.7_x nv driver has bad performance with xterm on GeForce 210 video card
Summary: x11/xorg: xorg-7.7_x nv driver has bad performance with xterm on GeForce 210 ...
Status: Closed Feedback Timeout
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 10.3-RELEASE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-x11 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-12 03:45 UTC by jguojun
Modified: 2018-06-10 06:46 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jguojun 2016-05-12 03:45:13 UTC
This problem seems started from 10.2-R, and the current X server is xorg-server-1.17.4 from 10.3-R.
Moving any X window around is very sluggish, and text message output to exposed xterm chews 100% CPU. For example, doing a large compiling from a xterm, when xterm in covered by another window, CPU is used only by the compiler; however, when this compiling xterm is exposed (can be seen), system becomes slow and top shows that xterm takes 100% CPU on one core.
Playing video on firefox does not have much performance issue.
It is not clear if this is a xterm issue or nv driver issue in xorg-7.7_x built under FreeBSD.

The xorg-7.5 (xorg-server 1.7.7 from 8.4-R) works very well with GeForce 210 card, and X from the latest Ubuntu release 16.04 LTS (xorg-server-1.18?) also work well on this video card.
Comment 1 Niclas Zeising freebsd_committer 2018-05-20 15:06:44 UTC
Is this still relevant?
Have you tried using the official binary drivers from nVidia?
Comment 2 Niclas Zeising freebsd_committer 2018-06-10 06:46:53 UTC
Feedback timeout