Bug 209510 - Port "mysql57-client-5.7.12" has wrong description
Summary: Port "mysql57-client-5.7.12" has wrong description
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on: 209458
Blocks: 209512
  Show dependency treegraph
 
Reported: 2016-05-15 00:31 UTC by Regulus Kean
Modified: 2016-05-17 20:02 UTC (History)
3 users (show)

See Also:


Attachments
Patch corrects variable to be overwritten by slave port (978 bytes, patch)
2016-05-16 15:43 UTC, Mahdi Mokhtari
mmokhi: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Regulus Kean 2016-05-15 00:31:45 UTC
This is my first bug report. I hope I am doing this right, and that this is not considered an inappropriate due how minor the bug is.

Either way, when I do "pkg search mysql57-client-5.7.12", the description of that port is given as "Multithreaded SQL database (server)", when it should say "(client)" instead.
Comment 1 Kurt Jaeger freebsd_committer 2016-05-15 20:13:03 UTC
The cause is that the COMMENT field in the databases/mysql57-client/Makefile
is set to (client), but overwritten by including the databases/mysql57-server/Makefile.

It probably should be set with COMMENT?= in the -server/Makefile.
Comment 2 Mahdi Mokhtari freebsd_committer freebsd_triage 2016-05-16 15:12:58 UTC
As a patch on other issue[#209458] is waiting to be committed in mysql57-server, i made this issue depended on that one (to avoid bundling changes for opened issues in one patch).
Comment 3 Mahdi Mokhtari freebsd_committer freebsd_triage 2016-05-16 15:43:19 UTC
Created attachment 170366 [details]
Patch corrects variable to be overwritten by slave port

Thanks to Markus, this patch marks variables to be over-writable, and so slave port (mysql57-client) will have its own Comments.
Comment 4 Mahdi Mokhtari freebsd_committer freebsd_triage 2016-05-16 15:43:57 UTC
QA: portlint -AC : done: no error.
Comment 5 Kurt Jaeger freebsd_committer 2016-05-17 18:25:37 UTC
Committed, thanks!
Comment 6 commit-hook freebsd_committer 2016-05-17 18:25:50 UTC
A commit references this bug:

Author: pi
Date: Tue May 17 18:25:20 UTC 2016
New revision: 415405
URL: https://svnweb.freebsd.org/changeset/ports/415405

Log:
  databases/mysql57-{client|server}: fix COMMENT for -client

  PR:		209510
  Reported by:	Regulus Kean <rkean@bitmessage.ch>
  Submitted by:	Mahdi Mokhtari <mokhi64@gmail.com> (maintainer)

Changes:
  head/databases/mysql57-client/Makefile
  head/databases/mysql57-server/Makefile
Comment 7 Mahdi Mokhtari freebsd_committer freebsd_triage 2016-05-17 20:02:29 UTC
Thanks all guys.
Good job ;)