Bug 209533 - FreeBSD iperf performance abnormal when iperf -s as server
Summary: FreeBSD iperf performance abnormal when iperf -s as server
Status: Closed DUPLICATE of bug 209658
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.3-RELEASE
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-testing mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-16 01:01 UTC by pengsb
Modified: 2016-10-06 12:19 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pengsb 2016-05-16 01:01:11 UTC
install four test systems on the same ESXi 6.0 update 2

FreeBSD10.3  IP 10.10.10.103
RHEL66       IP 10.10.10.66
FreeBSD10.3
RHEL66

netowrk Cards are vmxnet3, these test OS all in the same ESXi host, the same vswitcher, the same subnet, otherwise no adjustment is installed by default

When FreeBSD running iperf as server : iperf -s

Any other client iperf -c 10.10.10.103 (FreeBSD 10.3 IP address)
Speed is generally 7.xG

But RHEL66 run iperf as server: iperf -s
Any client iperf -c 10.10.10.66 (RHEL66 IP address)
Speeds of up to 30G, 38G highest

And then on another host ESXi6.0 update2 test, the situation is still so
FreeBSD run ipers -c as client ,speed can reach 38G
But FreeBSD run iperf -s as server, the speed only 8G

test result:

root@freebsd103:~ # uname -a
FreeBSD freebsd103 10.3-RELEASE-p2 FreeBSD 10.3-RELEASE-p2 #0: Wed May  4 06:03:51 UTC 2016     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
root@freebsd103:~ #
root@freebsd103:~ # iperf -s
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 64.0 KByte (default)
------------------------------------------------------------
[  4] local 10.10.10.103 port 5001 connected with 10.10.10.66 port 38535
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-10.0 sec  9.14 GBytes  7.85 Gbits/sec
^Croot@freebsd103:~ # iperf -c rhel66
------------------------------------------------------------
Client connecting to rhel66, TCP port 5001
TCP window size: 32.5 KByte (default)
------------------------------------------------------------
[  3] local 10.10.10.103 port 10056 connected with 10.10.10.66 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  45.2 GBytes  38.8 Gbits/sec
root@freebsd103:~ #
Comment 1 Tilman Keskinoz freebsd_committer 2016-10-06 12:19:49 UTC

*** This bug has been marked as a duplicate of bug 209658 ***