Bug 209630 - [maintainer-update] science/py-h5py: update to 2.6.0
Summary: [maintainer-update] science/py-h5py: update to 2.6.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks: 209746
  Show dependency treegraph
 
Reported: 2016-05-19 05:22 UTC by Johannes Jost Meixner
Modified: 2016-05-25 16:33 UTC (History)
2 users (show)

See Also:
pi: maintainer-feedback+


Attachments
update py-h5py to 2.6.0 (868 bytes, patch)
2016-05-19 05:22 UTC, Johannes Jost Meixner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Jost Meixner freebsd_committer 2016-05-19 05:22:47 UTC
Created attachment 170471 [details]
update py-h5py to 2.6.0

Patch attached updates science/py-h5py to 2.6.0.

Poudriere & portlint-tested.
Comment 1 Kurt Jaeger freebsd_committer 2016-05-19 05:40:09 UTC
testbuilds in poudriere are OK, but it has a strange failure mode:

http://people.freebsd.org/~pi/logs/h5py-build-issues.txt
Comment 2 Kurt Jaeger freebsd_committer 2016-05-19 16:37:28 UTC
See

http://people.freebsd.org/~pi/logs/h5py-build-issues-2.txt

for a second syndrome: The files of the port itself are mode 644 before
the build, 444 after the build. What's going on ?
Comment 3 Johannes Jost Meixner freebsd_committer 2016-05-19 20:36:59 UTC
(In reply to Kurt Jaeger from comment #1)
I can't reproduce this error with recent portstree in a poudriere jail set up with

poudriere testport -I -n -j 11amd64 -p svnports -o science/py-h5py.

I'm wondering, do you have
OPTIONS_UNSET= NLS somewhere in a make.conf?
Comment 4 Kurt Jaeger freebsd_committer 2016-05-19 20:39:35 UTC
It's not in poudriere, it's on a populated host (fc.opsec.eu). /etc/make.conf:

WITH_PKGNG=devel
DEVELOPER=yes
DEFAULT_VERSIONS= perl5=5.22 python=2.7 python3=3.4 ruby=2.3 pgsql=9.5 php=7.0
Comment 5 Kurt Jaeger freebsd_committer 2016-05-19 20:40:22 UTC
'populated host' means:


pkg info | wc -l
    1941
Comment 6 Johannes Jost Meixner freebsd_committer 2016-05-19 21:08:12 UTC
(In reply to Kurt Jaeger from comment #2)
I can't reproduce this error with poudriere either.
Comment 7 Kurt Jaeger freebsd_committer 2016-05-20 04:02:29 UTC
I made a test with make -d all
 
In line 691 of
 
http://people.freebsd.org/~pi/logs/h5py-build-issues-3.txt
 
this is executed:

(cd /home/pi/myp/science/py-h5py/work/h5py-2.6.0/docs) && /bin/sh -c '(/usr/bin/
find -d $0 $2 | /usr/bin/cpio -dumpl $1 >/dev/null  2>&1) &&  /usr/bin/find -d $
0 $2 -type d -exec chmod 755 $1/{} \; &&  /usr/bin/find -d $0 $2 -type f -exec c
hmod 444 $1/{} \;' -- . /home/pi/myp/science/py-h5py/work/stage/usr/local/share/
doc/h5py

There are many (>700) lines of failing chmod following.
Comment 8 Johannes Jost Meixner freebsd_committer 2016-05-20 06:44:28 UTC
(In reply to Kurt Jaeger from comment #7)
So, the line in question within the Makefile is this:

        @(cd ${WRKSRC}/docs) && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}

Which, on my system, works because it doesn't try to create the DOCSDIR twice 


chmod: /home/pi/myp/science/py-h5py/work/stage/usr/local/share/doc/h5py/./work/stage/usr/local/share/doc/h5py/work/h5py-2.6.0/docs/high: No such file or directory

it looks like your system is trying to copy everything into 

${DOCSDIR}${STAGEDIR}${DOCSDIR}

which it shouldn't do.

To verify, can you run `make -V STAGEDIR -V DOCSDIR`?

It should look like this - which is why your poudriere install works:

root@11amd64-svnports:/usr/ports/science/py-h5py # make -V STAGEDIR -V DOCSDIR
/wrkdirs/usr/ports/science/py-h5py/work/stage
/usr/local/share/doc/h5py
Comment 9 Johannes Jost Meixner freebsd_committer 2016-05-25 11:03:12 UTC
How do we move this forward?
Comment 10 Kurt Jaeger freebsd_committer 2016-05-25 16:02:25 UTC
(In reply to comment #8)
make -V STAGEDIR -V DOCSDIR says:

/home/pi/myp/science/py-h5py/work/stage
/usr/local/share/doc/h5py
Comment 11 Kurt Jaeger freebsd_committer 2016-05-25 16:11:52 UTC
(In reply to Kurt Jaeger from comment #10)

Before:

@(cd ${WRKSRC}/docs) && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}

After:

${COPYTREE_SHARE} ${WRKSRC}/docs ${STAGEDIR}${DOCSDIR}

works like a charm.
Comment 12 Kurt Jaeger freebsd_committer 2016-05-25 16:32:50 UTC
Committed, thanks. I did not find any changelog -- any ideas where it's hidden ?
Comment 13 commit-hook freebsd_committer 2016-05-25 16:33:24 UTC
A commit references this bug:

Author: pi
Date: Wed May 25 16:32:24 UTC 2016
New revision: 415847
URL: https://svnweb.freebsd.org/changeset/ports/415847

Log:
  science/py-h5py: 2.5.0 -> 2.6.0

  PR:		209630
  Submitted by:	Johannes Jost Meixner <xmj@chaot.net> (maintainer)

Changes:
  head/science/py-h5py/Makefile
  head/science/py-h5py/distinfo