Bug 209653 - biology/{htslib,samtools,bcftools}: Update to 1.3.1
Summary: biology/{htslib,samtools,bcftools}: Update to 1.3.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-05-19 21:35 UTC by cartwright
Modified: 2016-05-26 20:32 UTC (History)
1 user (show)

See Also:


Attachments
tar archive containing three patches and pounderie testport output (25.20 KB, application/x-compressed-tar)
2016-05-19 21:35 UTC, cartwright
cartwright: maintainer-approval+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cartwright 2016-05-19 21:35:52 UTC
Created attachment 170492 [details]
tar archive containing three patches and pounderie testport output

Update the following package to 1.3.1

biology/htslib
biology/samtools
biology/bcftools
Comment 1 cartwright 2016-05-19 21:39:15 UTC
Let me know if I need to upload everything separately.
Comment 2 Kurt Jaeger freebsd_committer 2016-05-20 15:43:02 UTC
testbuilds@work
Comment 3 cartwright 2016-05-26 05:12:58 UTC
Bump. Do I need to do anything?

Thanks.
Comment 4 Kurt Jaeger freebsd_committer 2016-05-26 07:07:37 UTC
I found some issues with one of the tree ports if built on a loaded system (outside of poudriere) and did not yet find the time to investigate.

I'll try to provide details, maybe we find a solution.
Comment 5 Kurt Jaeger freebsd_committer 2016-05-26 11:03:52 UTC
Here's the build log:

http://people.freebsd.org/~pi/logs/bcftools.txt

it fails because of issues with the installed port openssl.
Comment 6 Kurt Jaeger freebsd_committer 2016-05-26 11:23:04 UTC
Fix is: CONFLICTS_BUILD=openssl
Comment 7 VK freebsd_triage 2016-05-26 12:26:50 UTC
Thanks for your submission and the patch. But please in the future attach them in plain text as they're easily (re)viewable here in bugzilla which speeds up resolution. :)
Comment 8 cartwright 2016-05-26 20:17:27 UTC
I'm not sure where to begin with this issue.

BCFTools doesn't link directly against OpenSSL. It links with libhts, which links to lubcurl, which links to libssl.  Samtools does a similar thing, and it seems weird that it wouldn't also fail to link.

The issue appears to be triggered if OPENSSL_NO_SCTP was defined when building the library and not defined when linking/compiling against it.

I don't know if this is an biology/htslib issue, a curl issue, or an openssl issue.
Comment 9 commit-hook freebsd_committer 2016-05-26 20:29:46 UTC
A commit references this bug:

Author: pi
Date: Thu May 26 20:28:56 UTC 2016
New revision: 415914
URL: https://svnweb.freebsd.org/changeset/ports/415914

Log:
  biology/{htslib|samtools|bcftools}: 1.3 -> 1.3.1

  Changes:
    https://sourceforge.net/p/samtools/mailman/message/35033807/

  PR:		209653
  Submitted by:	cartwright@asu.edu (maintainer)

Changes:
  head/biology/bcftools/Makefile
  head/biology/bcftools/distinfo
  head/biology/bcftools/pkg-plist
  head/biology/htslib/Makefile
  head/biology/htslib/distinfo
  head/biology/samtools/Makefile
  head/biology/samtools/distinfo
  head/biology/samtools/files/patch-Makefile
Comment 10 Kurt Jaeger freebsd_committer 2016-05-26 20:32:08 UTC
(In reply to cartwright from comment #8)
I committed the updates now, most of the time the ports will be build using poudriere. I have not analyzed the root cause of the issue. If you find the time, try to find it -- and I know, it's not easy!