Bug 209710 - biology/seqan: Update pkg-plist
Summary: biology/seqan: Update pkg-plist
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Dmitry Marakasov
URL:
Keywords: easy, patch, patch-ready
: 209709 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-23 09:50 UTC by Hannes Hauswedell
Modified: 2016-05-27 16:11 UTC (History)
0 users

See Also:
h2+fbsdports: maintainer-feedback+


Attachments
add FindSeqAn.cmake and seqan-2.pc (1.52 KB, patch)
2016-05-23 11:00 UTC, Hannes Hauswedell
h2+fbsdports: maintainer-approval+
Details | Diff
fix pkgconfig path (1.46 KB, patch)
2016-05-23 15:28 UTC, Hannes Hauswedell
h2+fbsdports: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hannes Hauswedell 2016-05-23 09:50:52 UTC
The previous update did not install the pkgconfig and cmake modules unfortunately. This little patch adds them (and also simplifies the install instructions).
Comment 1 Hannes Hauswedell 2016-05-23 11:00:55 UTC
Created attachment 170565 [details]
add FindSeqAn.cmake and seqan-2.pc
Comment 2 VK freebsd_triage 2016-05-23 11:31:46 UTC
*** Bug 209709 has been marked as a duplicate of this bug. ***
Comment 3 Dmitry Marakasov freebsd_committer 2016-05-23 14:50:42 UTC
This is not correct. pkgconfig files should be installed into ${PREFIX}/libdata/pkgconfig
Comment 4 Hannes Hauswedell 2016-05-23 15:28:49 UTC
Created attachment 170574 [details]
fix pkgconfig path

fix the pkgconfig path
Comment 5 commit-hook freebsd_committer 2016-05-27 16:11:22 UTC
A commit references this bug:

Author: amdmi3
Date: Fri May 27 16:10:36 UTC 2016
New revision: 415945
URL: https://svnweb.freebsd.org/changeset/ports/415945

Log:
  - Do install cmake and pkgconfig modules
  - While here, switch to options helpers

  PR:		209710
  Submitted by:	h2+fbsdports@fsfe.org (maintainer)

Changes:
  head/biology/seqan/Makefile
  head/biology/seqan/pkg-plist