Bug 209796 - archivers/py-borgbackup: Update to 1.0.3
Summary: archivers/py-borgbackup: Update to 1.0.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Dmitry Marakasov
URL:
Keywords: easy, patch
Depends on:
Blocks:
 
Reported: 2016-05-27 16:05 UTC by jjuanino
Modified: 2016-05-28 19:52 UTC (History)
3 users (show)

See Also:


Attachments
Patch to update borgbackup from 1.0.2 to 1.0.3 (760 bytes, patch)
2016-05-27 16:05 UTC, jjuanino
jjuanino: maintainer-approval+
Details | Diff
Patch to update borgbackup from 1.0.2 to 1.0.3 (775 bytes, patch)
2016-05-28 14:33 UTC, jjuanino
jjuanino: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jjuanino 2016-05-27 16:05:15 UTC
Created attachment 170730 [details]
Patch to update borgbackup from 1.0.2 to 1.0.3

See the attached patch.

Changelog:

https://github.com/borgbackup/borg/blob/1.0.3/docs/changes.rst

Regards
Comment 1 VK freebsd_triage 2016-05-27 16:33:57 UTC
Thanks for the report. Please approve the patch by setting maintainer-approval+ since you're the maintainer. Please confirm it passes tests like portlint, poudriere.
Comment 2 jjuanino 2016-05-28 10:45:45 UTC
Hi,

portlint -aC throws me the following:

FATAL: /usr/ports/archivers/py-borgbackup/distinfo: [1]: line format error.

The cause is the line

TIMESTAMP = 1464364644

But that line was automatically added by "make makesum".

Regards
Comment 3 Dmitry Marakasov freebsd_committer 2016-05-28 12:57:42 UTC
The patch does not apply, has CRLF line terminators.
Comment 4 jjuanino 2016-05-28 14:33:05 UTC
Created attachment 170752 [details]
Patch to update borgbackup from 1.0.2 to 1.0.3
Comment 5 jjuanino 2016-05-28 14:37:46 UTC
I attach again the patch. Sorry for the annoyances.
Comment 6 commit-hook freebsd_committer 2016-05-28 19:52:07 UTC
A commit references this bug:

Author: amdmi3
Date: Sat May 28 19:51:51 UTC 2016
New revision: 416062
URL: https://svnweb.freebsd.org/changeset/ports/416062

Log:
  - Update to 1.0.3

  PR:		209796
  Submitted by:	jjuanino@gmail.com (maintainer)

Changes:
  head/archivers/py-borgbackup/Makefile
  head/archivers/py-borgbackup/distinfo