Bug 209849 - [NEW PORT] benchmarks/clpeak: Benchmarking tool to measure peak capabilities of opencl devices
Summary: [NEW PORT] benchmarks/clpeak: Benchmarking tool to measure peak capabilities ...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Roman Bogorodskiy
URL:
Keywords: feature, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2016-05-30 02:45 UTC by Johannes M Dieterich
Modified: 2016-06-27 11:00 UTC (History)
1 user (show)

See Also:


Attachments
shar archive for benchmarks/clpeak (2.36 KB, text/plain)
2016-05-30 02:45 UTC, Johannes M Dieterich
no flags Details
shar archive for benchmarks/clpeak with patch file (3.19 KB, text/plain)
2016-06-26 22:40 UTC, Johannes M Dieterich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes M Dieterich freebsd_committer 2016-05-30 02:45:42 UTC
Created attachment 170816 [details]
shar archive for benchmarks/clpeak

new port for clpeak attached. clpeak measures the performance of OpenCL execution on a particular platform+device through a few micro benchmarks. This is helpful for testing performance problems/regressions in bring-up of the new GPU drivers.

In the meantime, I tested it to work with pocl on a CPU device. pocl is not yet committed to the tree but would be an extremely welcome addition.

The port is portlint-clean.

The port has been tested on 11-CURRENT and using poudriere on 10.1 amd64. It is marked broken for 9 as OpenCL is not supported there and is not supported on anything but amd64 by upstream.
Comment 1 Roman Bogorodskiy freebsd_committer 2016-06-26 22:16:26 UTC
On 10.3-RELEASE build fails for me:

https://people.freebsd.org/~novel/misc/clpeak-1.0.log

Could you please take a look?
Comment 2 Johannes M Dieterich freebsd_committer 2016-06-26 22:39:22 UTC
Apparently I messed up the shar command and it did not include the patch file in the file directory. Sorry!
Comment 3 Johannes M Dieterich freebsd_committer 2016-06-26 22:40:23 UTC
Created attachment 171838 [details]
shar archive for benchmarks/clpeak with patch file
Comment 4 Roman Bogorodskiy freebsd_committer 2016-06-26 22:47:55 UTC
(In reply to dieterich from comment #2)

Yeah, I was wondering if there should be a patch because there was an empty 'files' dir in shar. OTOH, there was empty 'work' dir there as well (normally should not be included).

Anyway, thanks for the updated shar, things seem to move forward with that patch.
Comment 5 commit-hook freebsd_committer 2016-06-27 10:56:31 UTC
A commit references this bug:

Author: novel
Date: Mon Jun 27 10:56:15 UTC 2016
New revision: 417650
URL: https://svnweb.freebsd.org/changeset/ports/417650

Log:
  Add clpeak 1.0, benchmarking tool to measure peak capabilities of opencl
  devices.

  PR:		209849
  Submitted by:	Johannes Dieterich <dieterich@ogolem.org>

Changes:
  head/benchmarks/Makefile
  head/benchmarks/clpeak/
  head/benchmarks/clpeak/Makefile
  head/benchmarks/clpeak/distinfo
  head/benchmarks/clpeak/files/
  head/benchmarks/clpeak/files/patch-src_include_common.h
  head/benchmarks/clpeak/pkg-descr
Comment 6 Roman Bogorodskiy freebsd_committer 2016-06-27 11:00:02 UTC
Committed, thanks!