Bug 209864 - sysutils/3dm includes build hostname in pkg-message, makes package nonreproducible
Summary: sysutils/3dm includes build hostname in pkg-message, makes package nonreprodu...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL: https://reviews.freebsd.org/D6836
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-30 13:41 UTC by Ed Maste
Modified: 2016-06-27 19:30 UTC (History)
2 users (show)

See Also:
pi: maintainer-feedback+


Attachments
3dm-2.11.00.021_3,1.patch (3.56 KB, patch)
2016-06-15 05:16 UTC, takefu
takefu: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Maste freebsd_committer 2016-05-30 13:41:07 UTC
The sysutils/3dm package was nonreproducible in my recent test due (only) to differences in the pkg-message. One package reported "Visit https://current-master-job-06:888/" and the other "Visit https://current-master-job-22:888/". In the case of binary packages the build hostname is most likely not meaningful; this should probably be "Visit https://localhost:888/" or use example.org.
Comment 1 Mathieu Arnold freebsd_committer 2016-05-30 14:20:23 UTC
Mmm, poudriere has a BUILDER_HOSTNAME that sets the hostname to the jail as being the same for all jails, it's what's used to fix other ports that do the same things, sysutils/puppet comes to mind (it puts the hostname in the config file.)
Comment 2 Ed Maste freebsd_committer 2016-05-30 14:42:33 UTC
At least initially I don't want to set an option like that because I have a goal of determining the current state of package reproducibility.

I also believe it is better to address these at the source rather than coerce system inputs to make builds reproducible; for this case BUILDER_HOSTNAME would address the nonreproducibility, but the message still might not be useful for a user of the package.

3dm is not redistributable so this won't affect official FreeBSD packages but would for someone building their own package set.
Comment 3 Ed Maste freebsd_committer 2016-06-13 18:20:56 UTC
Review at https://reviews.freebsd.org/D6836
Comment 4 takefu 2016-06-15 05:16:24 UTC
Created attachment 171452 [details]
3dm-2.11.00.021_3,1.patch

Will also no problem to change from the hostname to localhost.
Simply it has inherited from #130295,
Not necessarily that particular stick.

I'm sorry too slow.
Comment 5 commit-hook freebsd_committer 2016-06-27 19:29:17 UTC
A commit references this bug:

Author: pi
Date: Mon Jun 27 19:29:07 UTC 2016
New revision: 417677
URL: https://svnweb.freebsd.org/changeset/ports/417677

Log:
  sysutils/3dm: fix hostname in pkg-message, make package reproducible

  PR:		209864
  Reported by:	emaste
  Submitted by:	takefu@airport.fm (maintainer)

Changes:
  head/sysutils/3dm/Makefile
  head/sysutils/3dm/distinfo
  head/sysutils/3dm/files/pkg-message.in
  head/sysutils/3dm/pkg-descr
Comment 6 Kurt Jaeger freebsd_committer 2016-06-27 19:30:29 UTC
Committed, thanks