Bug 209880 - net/asterisk11: crash in app_queue.c in 11.22.0
Summary: net/asterisk11: crash in app_queue.c in 11.22.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Guido Falsi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-31 06:01 UTC by emz
Modified: 2016-05-31 09:08 UTC (History)
0 users

See Also:
madpilot: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description emz 2016-05-31 06:01:06 UTC
There's a regression in asterisk-11.22.0, which has been patched in upstream, but since there wasn't a new release it remains active in ports version. This patchs needs needs to be commited in ports.

Please see the provided patch:

https://issues.asterisk.org/jira/browse/ASTERISK-25888
Comment 1 Guido Falsi freebsd_committer 2016-05-31 07:59:01 UTC
Hi,

Thanks for the report. Please allow me a little time to test the patch, I'll try to commit this ASAP.
Comment 2 Guido Falsi freebsd_committer 2016-05-31 09:07:52 UTC
Patch committed.

Thanks again for reporting this issue!
Comment 3 commit-hook freebsd_committer 2016-05-31 09:08:09 UTC
A commit references this bug:

Author: madpilot
Date: Tue May 31 09:07:20 UTC 2016
New revision: 416187
URL: https://svnweb.freebsd.org/changeset/ports/416187

Log:
  Import upstream patch to fix regression in app_queue module.

  PR:		209880
  Submitted by:	emz at norma.perm.ru
  Obtained from:	https://github.com/asterisk/asterisk/commit/32b4320d620ffff5c55f111fc22f22fdb07f8c60

Changes:
  head/net/asterisk11/Makefile
  head/net/asterisk11/files/patch-apps_app__queue.c