Bug 209890 - net-mgmt/zabbix2 (server/agent/proxy) Update to 2.0.18 and Fix PID
Summary: net-mgmt/zabbix2 (server/agent/proxy) Update to 2.0.18 and Fix PID
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Torsten Zuehlsdorff
URL:
Keywords: needs-patch, needs-qa, patch
: 212050 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-31 14:16 UTC by pg
Modified: 2016-09-01 12:21 UTC (History)
4 users (show)

See Also:


Attachments
patch (9.96 KB, patch)
2016-05-31 14:16 UTC, pg
vlad-fbsd: maintainer-approval-
Details | Diff
patch for zabbix2-* (10.59 KB, patch)
2016-06-07 14:15 UTC, pg
pg: maintainer-approval+
Details | Diff
patch to 2.0.18 (10.31 KB, patch)
2016-06-18 09:39 UTC, pg
pg: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description pg 2016-05-31 14:16:44 UTC
Created attachment 170866 [details]
patch

- Fix default path to PID 
- Fix rc.d scripts to correct use PID file
Comment 1 Bartek Rutkowski freebsd_committer 2016-06-03 14:52:50 UTC
Hi, the patch fails to apply cleanly, hunk 3 on files/zabbix_proxy.in fails.
Comment 2 VK freebsd_triage 2016-06-05 11:54:20 UTC
Fixing summary to make it searchable by individual port names. Needs new patch per comment #1.
Comment 3 VK freebsd_triage 2016-06-05 11:58:17 UTC
Comment on attachment 170866 [details]
patch

Patch does not apply, per comment #1, rejected. Please attach a one, please confirm it passes tests. ;)
Comment 4 pg 2016-06-07 14:15:11 UTC
Created attachment 171146 [details]
patch for zabbix2-*

apply cleanly
Comment 5 pg 2016-06-18 09:39:42 UTC
Created attachment 171540 [details]
patch to 2.0.18

- Fix default path to PID 
- Fix rc.d scripts to correct use PID file
- Update to 2.0.18

poudriere log does not contain errors:
# grep failure zabbix2-*-2.0.18.log     
#
Comment 6 Torsten Zuehlsdorff freebsd_committer 2016-07-22 14:56:16 UTC
Testbuilds brings up the QA issue:

====> Running Q/A tests (stage-qa)
Warning: you need USES=ssl
Error: /usr/local/sbin/zabbix_server is linked to /usr/local/lib/libpkg.so.3 from ports-mgmt/pkg but it is not declared as a dependency
Warning: you need LIB_DEPENDS+=libpkg.so:ports-mgmt/pkg

Can you please fix this=
Comment 7 pg 2016-08-01 13:33:23 UTC
This is inderect depends. The zabbix2 port doesn't depend from libpkg.so and doesn't require SSL.
libpkg.so required for netsnmp:
configure:9395: checking for main in -lnetsnmp
configure:9414: cc -o conftest -O2 -pipe  -fstack-protector -fno-strict-aliasing    -I/usr/local/include    -I/usr/local/include  -I/usr/local/include -I/include -I/usr/include -I. -I/usr/local/include  -I/usr/local/include -rdynamic   -L/usr/local/lib -fstack-protector  -L/usr/lib -L/lib -L/usr/local/lib -L/usr/local/lib conftest.c -lnetsnmp  -lkvm -lm -lexecinfo -ldevstat    -lm -lkvm -ldevstat -lnetsnmp -lcrypto -lelf -lpkg -lssp_nonshared -lcrypto >&5

and SSL for CURL:
#define LIBCURL_FEATURE_SSL 1
Comment 8 John Marino freebsd_committer 2016-08-23 01:37:10 UTC
*** Bug 212050 has been marked as a duplicate of this bug. ***
Comment 9 commit-hook freebsd_committer 2016-09-01 09:44:52 UTC
A commit references this bug:

Author: tz
Date: Thu Sep  1 09:44:44 UTC 2016
New revision: 421201
URL: https://svnweb.freebsd.org/changeset/ports/421201

Log:
  net-mgmt/zabbix2-server: Update from 2.0.17 to 2.0.18

  - updated French translation; thanks to Zabbix translators
  - enforced bash usage in mysql.size user parameter configuration
    script to avoid issues with different default shells;
    thanks to Timo Lindfors for reporting it
  - fixed timeout being too low when sending configuration data to
    active proxy
  - fixed loss of trailing whitespace in unquoted function parameters
    when creating calculated items with low level discovery

  Also:
  - Fix default path to PID
  - Fix rc.d scripts to correct use PID file
  - Remove IGNORE_WITH_MYSQL because referenced version was removed long ago

  PR:           209890
  Submitted by: pg@pakhom.spb.ru (maintainer)
  Approved by:  pi (mentor)

Changes:
  head/net-mgmt/zabbix2-server/Makefile
  head/net-mgmt/zabbix2-server/distinfo
  head/net-mgmt/zabbix2-server/files/patch-src_zabbix__agent_zabbix__agentd.c
  head/net-mgmt/zabbix2-server/files/patch-src_zabbix__proxy_proxy.c
  head/net-mgmt/zabbix2-server/files/patch-src_zabbix__server_server.c
  head/net-mgmt/zabbix2-server/files/zabbix_agentd.in
  head/net-mgmt/zabbix2-server/files/zabbix_proxy.in
  head/net-mgmt/zabbix2-server/files/zabbix_server.in
Comment 10 Torsten Zuehlsdorff freebsd_committer 2016-09-01 12:21:43 UTC
Committed, thanks!

Sorry it took so long, but the patch is also quite complicated and issues in the last version were found. I removed for example the IGNORE_WITH_MYSQL=41 statement, because there is no MySQL 4.1 in the portstree - its gone long ago. Also the patches were not created by "make makepatch" with will cause issues, so i recreated them.

Please consider to create a review at http://reviews.freebsd.org/ for such non-trivial patches in the future.

Now on to zabbix22 :)