Bug 209891 - net-mgmt/zabbix22 (server/agent/proxy) Update to 2.2.14 and Fix PID
Summary: net-mgmt/zabbix22 (server/agent/proxy) Update to 2.2.14 and Fix PID
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Torsten Zuehlsdorff
URL:
Keywords:
: 212051 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-31 14:20 UTC by pg
Modified: 2016-09-14 13:19 UTC (History)
3 users (show)

See Also:


Attachments
patch to fix PID issue (10.07 KB, patch)
2016-05-31 14:20 UTC, pg
pg: maintainer-approval+
Details | Diff
patch to 2.2.13 (12.09 KB, patch)
2016-06-18 09:17 UTC, pg
pg: maintainer-approval+
Details | Diff
patch to 2.2.14 (12.12 KB, patch)
2016-08-03 13:54 UTC, pg
pg: maintainer-approval+
Details | Diff
patch to 2.2.14 (12.42 KB, patch)
2016-08-05 20:59 UTC, pg
pg: maintainer-approval+
Details | Diff
patch to 2.2.14 (12.74 KB, patch)
2016-08-05 21:29 UTC, pg
pg: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description pg 2016-05-31 14:20:47 UTC
Created attachment 170867 [details]
patch to fix PID issue

- Fix default path to PID 
- Fix rc.d scripts to correct use PID file
Comment 1 pg 2016-06-18 09:17:02 UTC
Created attachment 171539 [details]
patch to 2.2.13

- Fix default path to PID 
- Fix rc.d scripts to correct use PID file
- Update to 2.2.13

poudriere log does not contain errors:
# grep failure zabbix22-*-2.2.13.log     
#
Comment 2 pg 2016-08-03 13:54:15 UTC
Created attachment 173227 [details]
patch to 2.2.14

- Update to 2.2.14
- Fix default path to PID 
- Fix rc.d scripts to correct use PID file

poudriere log does not contain errors:
# grep failure zabbix22-*-2.2.14.log     
#

portlint: 0 fatal errors
Comment 3 Torsten Zuehlsdorff freebsd_committer 2016-08-05 13:53:21 UTC
Please excuse my late response. Now i'm back with new hardware :)

Everything but one point is fine. I got this warning message:

===>  Returning to user credentials
/!\ zabbix22-server-2.2.14: Makefile warnings, please consider fixing /!\

USE_MYSQL is deprecated, please use USES=mysql:

Can you please address the issue?
Comment 4 pg 2016-08-05 20:59:25 UTC
Created attachment 173339 [details]
patch to 2.2.14

- Update to 2.2.14
- Fix default path to PID 
- Fix rc.d scripts to correct use PID file
- Fix MYSQL_USE -> USES+= mysql
- Fix PGSQL_USES -> USES+= pgsql
- Fix SQLITE_USES -> USES+= sqlit
Comment 5 pg 2016-08-05 21:29:40 UTC
Created attachment 173343 [details]
patch to 2.2.14

- Update to 2.2.14
- Fix default path to PID 
- Fix rc.d scripts to correct use PID file
- Fix MYSQL_USE -> USES+= mysql
- Fix PGSQL_USES -> USES+= pgsql
- Fix SQLITE_USES -> USES+= sqlite
- Fix CONFLICTS
Comment 6 Torsten Zuehlsdorff freebsd_committer 2016-08-09 13:35:53 UTC
Testbuilds at work
Comment 7 John Marino freebsd_committer 2016-08-23 01:35:37 UTC
*** Bug 212051 has been marked as a duplicate of this bug. ***
Comment 8 commit-hook freebsd_committer 2016-09-14 13:17:37 UTC
A commit references this bug:

Author: tz
Date: Wed Sep 14 13:17:25 UTC 2016
New revision: 422129
URL: https://svnweb.freebsd.org/changeset/ports/422129

Log:
  net-mgmt/zabbix22-server: Update from 2.2.12 to 2.2.14

  - http://www.zabbix.com/rn2.2.13.php
  - http://www.zabbix.com/rn2.2.14.php

  Also:
  - Fix default path to PID
  - Fix rc.d scripts to correct use PID file
  - Remove IGNORE_WITH_PHP and IGNORE_WITH_MYSQL because the
    ignored versions no longer exists

  PR:           209891
  Submitted by: pg@pakhom.spb.ru (maintainer)
  Approved by:  pi (mentor)

Changes:
  head/net-mgmt/zabbix22-server/Makefile
  head/net-mgmt/zabbix22-server/distinfo
  head/net-mgmt/zabbix22-server/files/patch-src_zabbix__agent_zabbix__agentd.c
  head/net-mgmt/zabbix22-server/files/patch-src_zabbix__proxy_proxy.c
  head/net-mgmt/zabbix22-server/files/patch-src_zabbix__server_server.c
  head/net-mgmt/zabbix22-server/files/pkg-message.in
  head/net-mgmt/zabbix22-server/files/zabbix_agentd.in
  head/net-mgmt/zabbix22-server/files/zabbix_proxy.in
  head/net-mgmt/zabbix22-server/files/zabbix_server.in
Comment 9 Torsten Zuehlsdorff freebsd_committer 2016-09-14 13:19:14 UTC
Committed, thanks! 

Same comments here like in zabbix2-server ticket.