Bug 209938 - www/redmine: update to 3.2.2
Summary: www/redmine: update to 3.2.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Torsten Zuehlsdorff
URL:
Keywords: patch
Depends on: 209936
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-01 14:36 UTC by Torsten Zühlsdorff
Modified: 2016-06-21 08:22 UTC (History)
6 users (show)

See Also:
pi: maintainer-feedback+


Attachments
path with update to 3.2.2 (60.14 KB, patch)
2016-06-01 14:36 UTC, Torsten Zühlsdorff
no flags Details | Diff
path with update to 3.2.2 - v.2 (60.14 KB, patch)
2016-06-03 10:08 UTC, Torsten Zühlsdorff
no flags Details | Diff
path with update to 3.2.2 - v.2 (121.80 KB, patch)
2016-06-03 10:09 UTC, Torsten Zühlsdorff
no flags Details | Diff
patch with update to 3.2.2 - v.3 (60.53 KB, patch)
2016-06-06 20:18 UTC, Steve Wills
no flags Details | Diff
path with update to 3.2.3 (62.61 KB, patch)
2016-06-20 15:08 UTC, Torsten Zühlsdorff
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Torsten Zühlsdorff 2016-06-01 14:36:07 UTC
Created attachment 170916 [details]
path with update to 3.2.2

Hello,

there is a long standing work on getting an update for Redmine. I do not have this much experience with the port and the attached patch is clearly just a DRAFT for TESTING.

So please - test it, patch it, comment it. Lets make Redmine actual again! :)

Greetings,
Torsten
Comment 1 Kurt Jaeger freebsd_committer 2016-06-01 16:58:12 UTC
During build on current:

[cur-default] |   `-- Extracting rubygem-rack-ssl-1.4.1_1,1: .......... done
pkg-static: rubygem-railties-3.2.22.2 conflicts with rubygem-railties4-4.2.6 (installs files into the same place).  Problematic file: /usr/local/bin/rails
Comment 2 Torsten Zühlsdorff 2016-06-02 05:36:46 UTC
(In reply to Kurt Jaeger from comment #1)

Which revision did your current have? I did not see the error, but mine is older.
Comment 3 Kurt Jaeger freebsd_committer 2016-06-02 06:06:26 UTC
It's at r299220.
Comment 4 Torsten Zühlsdorff 2016-06-02 13:10:17 UTC
(In reply to Kurt Jaeger from comment #3)

> It's at r299220.

After upgrading to r301193 i could not build perl, autoconf, gmake and nearly everything other... I suspect its due my host is still 10.2. Is your host 10.3?
Comment 5 Torsten Zühlsdorff 2016-06-02 13:11:01 UTC
Ah, forgot to question: did you use -C or -c for a build? Sometimes there are problems when there are existing packages reused for a testbuild.
Comment 6 Kurt Jaeger freebsd_committer 2016-06-02 13:31:01 UTC
host is @r299224M
Comment 7 Torsten Zühlsdorff 2016-06-03 08:24:54 UTC
That is bad. I currently have no possibility to get a current machine :( Did you try the build test with -c in poudriere? I assume there could be a problem with precompiled packages.
Comment 8 Torsten Zühlsdorff 2016-06-03 10:08:51 UTC
Created attachment 170966 [details]
path with update to 3.2.2 - v.2

I found the issue - but its a little bit funny. At least the issue is on *every* version, but since i used -C instead of -c for poudriere, the problem did not occurs to me. With -c it hits me every time. 

Attached patch is supposed to fix the found build bug! :)
Comment 9 Torsten Zühlsdorff 2016-06-03 10:09:51 UTC
Created attachment 170967 [details]
path with update to 3.2.2 - v.2
Comment 10 Kurt Jaeger freebsd_committer 2016-06-04 06:05:34 UTC
(In reply to Torsten Zühlsdorff from comment #5)
I use

poudriere testport -j <arch> -o <port> -n 

so no -c or -C.
Comment 11 Kurt Jaeger freebsd_committer 2016-06-04 06:29:26 UTC
(In reply to Torsten Zühlsdorff from comment #9)
testbuilds at work
Comment 12 Kurt Jaeger freebsd_committer 2016-06-04 14:04:07 UTC
testbuilds OK
Comment 13 Steve Wills freebsd_committer 2016-06-06 20:18:36 UTC
Created attachment 171100 [details]
patch with update to 3.2.2 - v.3

Here's an updated patch. I did some testing and had to make these changes for it to work right for me. With this, I'm able to use it without issues.

Post install I had to change ownership of Gemfile.lock to user nobody, but I think this is normal for my setup with Passenger. At least, I had to do this before too. I also had to change ownership of the files directory.

After doing that and migrating my database, it seems to work fine.
Comment 14 Torsten Zühlsdorff 2016-06-20 15:08:11 UTC
Created attachment 171612 [details]
path with update to 3.2.3

Revised patch including new version :)
Comment 15 Miroslav Lachman 2016-06-20 15:20:45 UTC
Thank you Torsten for working on Redmine port. It needs a lot of care for a long time!
I tried your previous 3.2.0 version and now I tired 3.2.2 - works without any problem! (I did not tested any plugins yet)
I will try 3.2.3 and plugins soon.

Built in my Poudrier with MariaDB 5.5, tested in 10.3 jail with Thin and published through Apache reverse proxy from parent host. All works.
Comment 16 commit-hook freebsd_committer 2016-06-21 08:21:29 UTC
A commit references this bug:

Author: tz
Date: Tue Jun 21 08:21:24 UTC 2016
New revision: 417191
URL: https://svnweb.freebsd.org/changeset/ports/417191

Log:
  www/redmine: Update from 2.6.9 to 3.2.3

  Changelog: https://www.redmine.org/projects/redmine/wiki/Changelog

  A big thanks for the preparation of that update to swills

  PR:          209938
  Approved by: swills (ruby, mentor)

Changes:
  head/UPDATING
  head/www/redmine/Makefile
  head/www/redmine/distinfo
  head/www/redmine/files/ldap.rb
  head/www/redmine/files/markdown.rb
  head/www/redmine/files/mysql.rb
  head/www/redmine/files/patch-Gemfile
  head/www/redmine/files/pg.rb
  head/www/redmine/files/rmagic.rb
  head/www/redmine/pkg-plist
Comment 17 Torsten Zuehlsdorff freebsd_committer 2016-06-21 08:22:38 UTC
Committed! :)

Thanks to all your help on the various areas!