Bug 209952 - www/firefox: Compilation failed unexpectedly
Summary: www/firefox: Compilation failed unexpectedly
Status: Closed DUPLICATE of bug 200845
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-gecko mailing list
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2016-06-02 05:12 UTC by mikhail.rokhin
Modified: 2016-06-05 20:26 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikhail.rokhin 2016-06-02 05:12:56 UTC
INPUT("StaticXULComponentsEnd/StaticXULComponentsEnd.o")

../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/Unified_cpp_js_src24.o: multiple definition of '__dtrace_javascript___object-create'
../../build/unix/gold/ld: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/jsarray.o: previous definition here
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/Unified_cpp_js_src24.o: multiple definition of '__dtraceenabled_javascript___object-create'
../../build/unix/gold/ld: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/jsarray.o: previous definition here
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/Unified_cpp_js_src33.o: multiple definition of '__dtraceenabled_javascript___function-return'
../../build/unix/gold/ld: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/Unified_cpp_js_src13.o: previous definition here
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/Unified_cpp_js_src9.o: multiple definition of '__dtraceenabled_javascript___function-return'
../../build/unix/gold/ld: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/Unified_cpp_js_src13.o: previous definition here
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library/../../js/src/js-dtrace.o:/usr/src/cddl/lib/drti/../../../cddl/contrib/opensolaris/lib/libdtrace/common/drti.c:__SUNW_dof: error: unexpected reloc 8 in object file
../../media/libstagefright/libMP4Metadata.a(std-d16b8f0e.0.o):std.0.rs:function std::env::vars_os::heb1625c3932312c4: warning: undefined reference to 'environ'
../../media/libstagefright/libMP4Metadata.a(std-d16b8f0e.0.o):std.0.rs:function std::sys::process::Command::do_exec::hfe514bf35c2add20: warning: undefined reference to 'environ'
c++: error: linker command failed with exit code 1 (use -v to see invocation)
/usr/ports/www/firefox/work/firefox-46.0.1/config/rules.mk:834: recipe for target 'libxul.so' failed
gmake[6]: *** [libxul.so] Error 1
gmake[6]: Leaving directory '/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0/toolkit/library'
/usr/ports/www/firefox/work/firefox-46.0.1/config/recurse.mk:71: recipe for target 'toolkit/library/target' failed
gmake[5]: *** [toolkit/library/target] Error 2
gmake[5]: Leaving directory '/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0'
/usr/ports/www/firefox/work/firefox-46.0.1/config/recurse.mk:32: recipe for target 'compile' failed
gmake[4]: *** [compile] Error 2
gmake[4]: Leaving directory '/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0'
/usr/ports/www/firefox/work/firefox-46.0.1/config/rules.mk:557: recipe for target 'default' failed
gmake[3]: *** [default] Error 2
gmake[3]: Leaving directory '/usr/ports/www/firefox/work/firefox-46.0.1/obj-x86_64-portbld-freebsd11.0'
/usr/ports/www/firefox/work/firefox-46.0.1/client.mk:396: recipe for target 'realbuild' failed
gmake[2]: *** [realbuild] Error 2
gmake[2]: Leaving directory '/usr/ports/www/firefox/work/firefox-46.0.1'
/usr/ports/www/firefox/work/firefox-46.0.1/client.mk:171: recipe for target 'build' failed
gmake[1]: *** [build] Error 2
gmake[1]: Leaving directory '/usr/ports/www/firefox/work/firefox-46.0.1'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make: stopped in /usr/ports/www/firefox

===>>> make build failed for www/firefox
===>>> Aborting update

===>>> There are messages from installed ports to display,
       but first take a moment to review the error messages
       above.  Then press Enter when ready to proceed. 
===>>>
Comment 1 VK freebsd_triage 2016-06-02 23:00:25 UTC
Thanks for the problem report, Mikhail. Did you perhaps try like the error message suggested, and retry the build with MAKE_JOBS_UNSAFE=yes ?
Comment 2 commit-hook freebsd_committer 2016-06-03 10:53:28 UTC
A commit references this bug:

Author: jbeich
Date: Fri Jun  3 10:52:46 UTC 2016
New revision: 416309
URL: https://svnweb.freebsd.org/changeset/ports/416309

Log:
  www/firefox: update to 47.0 (rc2) / 45.2esr

  - Adjust firefox-esr-i18n for linux-firefox after r414580
  - Unbreak DTRACE=on + DEBUG=on [1]
  - Unbreak FFMPEG=off [2]

  Changes:	https://www.mozilla.org/firefox/47.0/releasenotes/
  Changes:	https://www.mozilla.org/firefox/45.2.0/releasenotes/
  Security:	8065d37b-8e7c-4707-a608-1b0a2b8509c3
  PR:		200845, 209952 [1], 209308 [2]
  MFH:		2016Q2

Changes:
  head/Mk/Uses/gecko.mk
  head/Mk/bsd.gecko.mk
  head/www/firefox/Makefile
  head/www/firefox/distinfo
  head/www/firefox/files/patch-bug1021761
  head/www/firefox/files/patch-bug1239550
  head/www/firefox/files/patch-bug1242132
  head/www/firefox/files/patch-bug1243312
  head/www/firefox/files/patch-bug1252246
  head/www/firefox/files/patch-bug1269165
  head/www/firefox/files/patch-bug826985
  head/www/firefox/files/patch-bug847568
  head/www/firefox/files/patch-ijg-libjpeg
  head/www/firefox/files/patch-sample-type
  head/www/firefox/files/patch-z-bug517422
  head/www/firefox-esr/Makefile
  head/www/firefox-esr/distinfo
  head/www/firefox-esr/files/patch-bug1269165
  head/www/firefox-esr-i18n/Makefile
  head/www/firefox-esr-i18n/distinfo
  head/www/firefox-i18n/Makefile
  head/www/firefox-i18n/Makefile.lang
  head/www/firefox-i18n/Makefile.option
  head/www/firefox-i18n/distinfo
  head/www/libxul/Makefile
  head/www/libxul/distinfo
  head/www/linux-firefox/Makefile
  head/www/linux-firefox/distinfo
Comment 3 Jan Beich freebsd_committer 2016-06-03 11:15:32 UTC
The error looks like the one in bug 200845. Try again after update and reopen that bug if it still fails.

*** This bug has been marked as a duplicate of bug 200845 ***
Comment 4 commit-hook freebsd_committer 2016-06-05 20:26:45 UTC
A commit references this bug:

Author: jbeich
Date: Sun Jun  5 20:25:45 UTC 2016
New revision: 416430
URL: https://svnweb.freebsd.org/changeset/ports/416430

Log:
  MFH: r416309 r416312 r416394

  www/firefox: update to 47.0 (rc3) / 45.2esr

  - Adjust firefox-esr-i18n for linux-firefox after r414580
  - Unbreak DTRACE=on + DEBUG=on [1]
  - Unbreak FFMPEG=off [2]

  Changes:	https://www.mozilla.org/firefox/47.0/releasenotes/
  Changes:	https://www.mozilla.org/firefox/45.2.0/releasenotes/
  Security:	8065d37b-8e7c-4707-a608-1b0a2b8509c3
  PR:		200845, 209952 [1], 209308 [2]
  Approved by:	ports-secteam (feld, junovitch)

Changes:
_U  branches/2016Q2/
  branches/2016Q2/Mk/Uses/gecko.mk
  branches/2016Q2/Mk/bsd.gecko.mk
  branches/2016Q2/www/firefox/Makefile
  branches/2016Q2/www/firefox/distinfo
  branches/2016Q2/www/firefox/files/patch-bug1021761
  branches/2016Q2/www/firefox/files/patch-bug1239550
  branches/2016Q2/www/firefox/files/patch-bug1242132
  branches/2016Q2/www/firefox/files/patch-bug1243312
  branches/2016Q2/www/firefox/files/patch-bug1252246
  branches/2016Q2/www/firefox/files/patch-bug1269165
  branches/2016Q2/www/firefox/files/patch-bug826985
  branches/2016Q2/www/firefox/files/patch-bug847568
  branches/2016Q2/www/firefox/files/patch-ijg-libjpeg
  branches/2016Q2/www/firefox/files/patch-sample-type
  branches/2016Q2/www/firefox/files/patch-z-bug517422
  branches/2016Q2/www/firefox-esr/Makefile
  branches/2016Q2/www/firefox-esr/distinfo
  branches/2016Q2/www/firefox-esr/files/patch-bug1269165
  branches/2016Q2/www/firefox-esr-i18n/Makefile
  branches/2016Q2/www/firefox-esr-i18n/distinfo
  branches/2016Q2/www/firefox-i18n/Makefile
  branches/2016Q2/www/firefox-i18n/Makefile.lang
  branches/2016Q2/www/firefox-i18n/Makefile.option
  branches/2016Q2/www/firefox-i18n/distinfo
  branches/2016Q2/www/libxul/Makefile
  branches/2016Q2/www/libxul/distinfo
  branches/2016Q2/www/libxul/files/patch-bug1269165
  branches/2016Q2/www/linux-firefox/Makefile
  branches/2016Q2/www/linux-firefox/distinfo