Bug 209970 - /etc/rc.d/ntpd not updating /var/db/ntpd.leapseconds.list
Summary: /etc/rc.d/ntpd not updating /var/db/ntpd.leapseconds.list
Status: Closed DUPLICATE of bug 209577
Alias: None
Product: Base System
Classification: Unclassified
Component: conf (show other bugs)
Version: 10.3-RELEASE
Hardware: Any Any
: --- Affects Many People
Assignee: Cy Schubert
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-02 13:50 UTC by mvharding
Modified: 2016-06-14 03:55 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mvharding 2016-06-02 13:50:14 UTC
'/etc/rc.d/ntpd fetch' does not update /var/db/ntpd.leapseconds.list.  In looking at the file I have (on 10.3) vs. https://www.ietf.org/timezones/data/leap-seconds.list, it appears the the version number has gone backwards in the ietf.org version, but the expiry has moved forward.  This is probably harmless, but caused me some confusion as the file is now expired.

If I type

# service ntpd fetch
ntp_src_leapfile version is 3660508800
ntp_db_leapfile version is 3660508800
not replacing /var/db/ntpd.leap-seconds.list with /etc/ntp/leap-seconds
Within ntp leapfile expiry limit, initiating fetch
fetching https://www.ietf.org/timezones/data/leap-seconds.list
using existing /var/db/ntpd.leap-seconds.list

The version and expiry on the ietf site are:
#$	 3629404800
#@	3691872000

and for the file in /var/db (sourced from somewhere in the FreeBSD tree, I think, it has FreeBSD svn info in it):
#$       3660508800
#@      3673728000
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2016-06-13 15:49:35 UTC
Cy, is this code you are maintaining?
Comment 2 Cy Schubert freebsd_committer 2016-06-14 03:55:46 UTC

*** This bug has been marked as a duplicate of bug 209577 ***