Bug 209972 - www/webkit2-gtk3: Build fails with "Call to 'pow' is ambiguous" error
Summary: www/webkit2-gtk3: Build fails with "Call to 'pow' is ambiguous" error
Status: Closed DUPLICATE of bug 209686
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-gnome mailing list
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2016-06-02 14:37 UTC by mikhail.rokhin
Modified: 2016-06-05 07:26 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikhail.rokhin 2016-06-02 14:37:07 UTC
[ 56%] Building CXX object Source/WebCore/CMakeFiles/WebCore.dir/rendering/shapes/RasterShape.cpp.o
[ 56%] Building CXX object Source/WebCore/CMakeFiles/WebCore.dir/rendering/shapes/RectangleShape.cpp.o
[ 56%] Building CXX object Source/WebCore/CMakeFiles/WebCore.dir/rendering/shapes/Shape.cpp.o
[ 56%] Building CXX object Source/WebCore/CMakeFiles/WebCore.dir/rendering/shapes/ShapeOutsideInfo.cpp.o
/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.8.5/Source/WebCore/rendering/shapes/BoxShape.cpp:46:40: error: call
      to 'pow' is ambiguous
        return radius + (margin * (1 + pow(ratio - 1, 3)));
                                       ^~~
/usr/include/math.h:251:8: note: candidate function
double  pow(double, double);
        ^
/usr/include/c++/v1/math.h:869:46: note: candidate function
inline _LIBCPP_INLINE_VISIBILITY float       pow(float __lcpp_x, float __lcpp_y) _NOEXCEPT             {re...
                                             ^
/usr/include/c++/v1/math.h:870:46: note: candidate function
inline _LIBCPP_INLINE_VISIBILITY long double pow(long double __lcpp_x, long double __lcpp_y) _NOEXCEPT {re...
                                             ^
[ 56%] Building CXX object Source/WebCore/CMakeFiles/WebCore.dir/rendering/style/BasicShapes.cpp.o                
1 error generated.
Source/WebCore/CMakeFiles/WebCore.dir/build.make:48234: recipe for target 'Source/WebCore/CMakeFiles/WebCore.dir/rendering/shapes/BoxShape.cpp.o' failed
gmake[3]: *** [Source/WebCore/CMakeFiles/WebCore.dir/rendering/shapes/BoxShape.cpp.o] Error 1
gmake[3]: *** Waiting for unfinished jobs....
gmake[3]: Leaving directory '/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.8.5'
CMakeFiles/Makefile2:714: recipe for target 'Source/WebCore/CMakeFiles/WebCore.dir/all' failed
gmake[2]: *** [Source/WebCore/CMakeFiles/WebCore.dir/all] Error 2
gmake[2]: Leaving directory '/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.8.5'
Makefile:149: recipe for target 'all' failed
gmake[1]: *** [all] Error 2
gmake[1]: Leaving directory '/usr/ports/www/webkit2-gtk3/work/webkitgtk-2.8.5'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make: stopped in /usr/ports/www/webkit2-gtk3

===>>> make build failed for www/webkit2-gtk3
===>>> Aborting update

===>>> Update for www/webkit2-gtk3 failed
===>>> Aborting update

===>>> Update for net/gnome-online-accounts failed
===>>> Aborting update

===>>> Update for devel/libgdata failed
===>>> Aborting update

===>>> Update for devel/gvfs failed
===>>> Aborting update

===>>> Update for archivers/file-roller failed
===>>> Aborting update

===>>> There are messages from installed ports to display,
       but first take a moment to review the error messages
       above.  Then press Enter when ready to proceed.
Comment 1 Antoine Brodin freebsd_committer 2016-06-05 07:26:41 UTC

*** This bug has been marked as a duplicate of bug 209686 ***