Bug 209973 - sysutils/vagrant: Doesn't run, requires misc/rubygem-mime-types version < 3.0
Summary: sysutils/vagrant: Doesn't run, requires misc/rubygem-mime-types version < 3.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: Steve Wills
URL:
Keywords: needs-qa, regression
Depends on:
Blocks:
 
Reported: 2016-06-02 15:38 UTC by mvharding
Modified: 2016-08-11 13:40 UTC (History)
2 users (show)

See Also:
joe: maintainer-feedback+
koobs: merge-quarterly?


Attachments
vagrant 1.8.5 update patch (41.93 KB, patch)
2016-08-10 14:20 UTC, Steve Wills
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mvharding 2016-06-02 15:38:39 UTC
vagrant does't start because it wants the mime-types gem to be version < 3.0, and a recent upgrade of misc/rubygem-mime-types pushed it to 3.1.

$ time vagrant up
/usr/local/lib/ruby/site_ruby/2.2/rubygems/dependency.rb:310:in `to_specs': Could not find 'mime-types' (< 3.0, >= 1.16) - did find: [mime-types-3.1] (Gem::MissingSpecVersionError)
...

As a work around I did:
gem install --user-install mime-types -v 2.99.2
and it appears to be working
Comment 1 Steve Wills freebsd_committer 2016-06-27 13:39:52 UTC
This is due to www/rubygem-rest-client specifically. I'll create a misc/rubygem-mime-types30 and change rubygem-rest-client to use it.
Comment 2 Steve Wills freebsd_committer 2016-06-27 13:45:52 UTC
(In reply to Steve Wills from comment #1)
Correction, it should be mime-types 2.99.2, since the requirement is < (less than) 3.0, not = (equal) 3.0. So it will be misc/mime-types29.
Comment 3 commit-hook freebsd_committer 2016-06-27 13:56:44 UTC
A commit references this bug:

Author: swills
Date: Mon Jun 27 13:56:06 UTC 2016
New revision: 417660
URL: https://svnweb.freebsd.org/changeset/ports/417660

Log:
  misc/rubygem-mime-types29: Create port

  Create port for rubygem-mime-types at 2.99.x which is needed by some gems,
  specifically www/rubygem-rest-client.

  PR:		209973

Changes:
  head/misc/Makefile
  head/misc/rubygem-mime-types29/
  head/misc/rubygem-mime-types29/Makefile
  head/misc/rubygem-mime-types29/distinfo
Comment 4 commit-hook freebsd_committer 2016-06-27 13:58:46 UTC
A commit references this bug:

Author: swills
Date: Mon Jun 27 13:58:04 UTC 2016
New revision: 417661
URL: https://svnweb.freebsd.org/changeset/ports/417661

Log:
  www/rubygem-rest-client: update dependency

  Update dependency to use proper version of mime-types. While here, update web
  site.

  PR:		209973
  With hat:	ruby@

Changes:
  head/www/rubygem-rest-client/Makefile
  head/www/rubygem-rest-client/pkg-descr
Comment 5 Steve Wills freebsd_committer 2016-06-27 14:12:31 UTC
I think this should be solved now, but have only tested with a newer version of vagrant which I have locally. I can work on updating vagrant in a separate PR since it will require maintainer approval and updates to three other ports (bundler, winrm and winrm-fs). Could you test that the older version of vagrant works with just the changes committed? Sorry this has taken so long to get fixed.
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2016-07-20 08:23:00 UTC
Assign to committer resolving
Comment 7 mvharding 2016-07-20 17:52:30 UTC
I can confirm that vagrant (from ports) seems to work after removing my local ~/.gem directory.  I also see:

$ pkg info | grep mime
...
rubygem-mime-types-3.1         Ruby gem which provides a mailcap-like MIME Content-Type lookup
...
rubygem-mime-types29-2.99.2    Ruby gem which provides a mailcap-like MIME Content-Type lookup
...

I did the update via poudriere so I wasn't 'aware' per se of the update to the package(s) but is looks good.
Comment 8 Steve Wills freebsd_committer 2016-08-10 14:20:08 UTC
Created attachment 173510 [details]
vagrant 1.8.5 update patch

Attached patch updates the port to 1.8.5 and solves the problem.
Comment 9 joe 2016-08-10 18:54:29 UTC
Comment on attachment 173510 [details]
vagrant 1.8.5 update patch

Patch looks good for commit.
Comment 10 commit-hook freebsd_committer 2016-08-11 13:34:18 UTC
A commit references this bug:

Author: swills
Date: Thu Aug 11 13:34:09 UTC 2016
New revision: 420069
URL: https://svnweb.freebsd.org/changeset/ports/420069

Log:
  sysutils/vagrant: update to 1.8.5

  Also update to work with new rubygem-mime-types version

  PR:		209973
  Approved by:	joe@thrallingpenguin.com (maintainer)

Changes:
  head/sysutils/vagrant/Makefile
  head/sysutils/vagrant/distinfo
  head/sysutils/vagrant/files/patch-gemspec
  head/sysutils/vagrant/files/patch-lib_vagrant_bundler
  head/sysutils/vagrant/pkg-plist
Comment 11 Steve Wills freebsd_committer 2016-08-11 13:40:54 UTC
Should be fixed, update is committed. Thanks all!