Bug 210045 - devel/py-qt4-core: should depend on devel/py-sip
Summary: devel/py-qt4-core: should depend on devel/py-sip
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks: 210255
  Show dependency treegraph
 
Reported: 2016-06-05 09:10 UTC by Antoine Brodin
Modified: 2016-06-14 18:19 UTC (History)
2 users (show)

See Also:
pi: maintainer-feedback-


Attachments
Readd sip as a run-time dependency to devel/py-qt4-core (1.99 KB, patch)
2016-06-14 15:11 UTC, Tobias Berner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Antoine Brodin freebsd_committer 2016-06-05 09:10:12 UTC
Since a few days,  devel/py-qt4-core no longer depends on devel/py-sip

I believe it should:

/usr/local/lib/python2.7/site-packages/PyQt4/pyqtconfig.py:22:import sipconfig

I marked a few ports BROKEN yesterday probably because of this:

science/veusz :
https://svnweb.freebsd.org/changeset/ports/416359

math/qtiplot :
https://svnweb.freebsd.org/changeset/ports/416369

emulators/swine :
https://svnweb.freebsd.org/changeset/ports/416370
Comment 1 Antoine Brodin freebsd_committer 2016-06-10 05:59:21 UTC
I marked devel/ninja-ide broken today:
https://svnweb.freebsd.org/changeset/ports/416654
Comment 2 Tobias Berner 2016-06-14 15:11:24 UTC
Created attachment 171429 [details]
Readd sip as a run-time dependency to devel/py-qt4-core

devel/py-sip was made a build-depend only in a recent commit. However <...>/PyQt4/pyqtconfig.py of py-qt4-core includes sipconfig, and therefore needs sip also at runtime.


The attached patch also revertes the BROKEN on the four ports mentioned by antoine.



Tested in poudriere, on 11-current.
Comment 3 commit-hook freebsd_committer 2016-06-14 18:19:06 UTC
A commit references this bug:

Author: pi
Date: Tue Jun 14 18:18:55 UTC 2016
New revision: 416904
URL: https://svnweb.freebsd.org/changeset/ports/416904

Log:
  devel/py-qt4-core: change USE_PYQT from sip_build to sip to fix build

  for those ports, unbreak:
    science/veusz
    math/qtiplot
    emulators/swine
    devel/ninja-ide

  PR:		210045
  Reported by:	antoine
  Submitted by:	Tobias C.Berner <tcberner@gmail.com> (kde)

Changes:
  head/devel/ninja-ide/Makefile
  head/devel/py-qt4-core/Makefile
  head/emulators/swine/Makefile
  head/math/qtiplot/Makefile
  head/science/veusz/Makefile
Comment 4 Kurt Jaeger freebsd_committer 2016-06-14 18:19:19 UTC
Committed, thanks!