Bug 210108 - sysutils/pick: Update to 1.4.0
Summary: sysutils/pick: Update to 1.4.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-07 17:12 UTC by Neel Chauhan
Modified: 2016-06-09 00:31 UTC (History)
2 users (show)

See Also:


Attachments
Patch to update sysutils/pick to 1.4.0 (810 bytes, patch)
2016-06-07 17:12 UTC, Neel Chauhan
nc: maintainer-approval+
Details | Diff
Poudriere build log for sysutils/pick 1.4.0 on FreeBSD 10.3 amd64 (13.16 KB, text/plain)
2016-06-07 17:13 UTC, Neel Chauhan
no flags Details
Poudriere build log for sysutils/pick 1.4.0 on FreeBSD 10.3 i386 (12.96 KB, text/plain)
2016-06-07 17:14 UTC, Neel Chauhan
no flags Details
Poudriere build log for sysutils/pick 1.4.0 on FreeBSD 9.3 amd64 (12.44 KB, text/plain)
2016-06-07 17:15 UTC, Neel Chauhan
no flags Details
Poudriere build log for sysutils/pick 1.4.0 on FreeBSD 9.3 i386 (12.38 KB, text/plain)
2016-06-07 17:16 UTC, Neel Chauhan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Neel Chauhan freebsd_committer 2016-06-07 17:12:39 UTC
Created attachment 171157 [details]
Patch to update sysutils/pick to 1.4.0
Comment 1 Neel Chauhan freebsd_committer 2016-06-07 17:13:21 UTC
Created attachment 171158 [details]
Poudriere build log for sysutils/pick 1.4.0 on FreeBSD 10.3 amd64
Comment 2 Neel Chauhan freebsd_committer 2016-06-07 17:14:00 UTC
Created attachment 171159 [details]
Poudriere build log for sysutils/pick 1.4.0 on FreeBSD 10.3 i386
Comment 3 Neel Chauhan freebsd_committer 2016-06-07 17:15:19 UTC
Created attachment 171160 [details]
Poudriere build log for sysutils/pick 1.4.0 on FreeBSD 9.3 amd64
Comment 4 Neel Chauhan freebsd_committer 2016-06-07 17:16:03 UTC
Created attachment 171161 [details]
Poudriere build log for sysutils/pick 1.4.0 on FreeBSD 9.3 i386
Comment 5 Kurt Jaeger freebsd_committer 2016-06-09 00:31:08 UTC
Committed, thanks!
Comment 6 commit-hook freebsd_committer 2016-06-09 00:31:49 UTC
A commit references this bug:

Author: pi
Date: Thu Jun  9 00:30:54 UTC 2016
New revision: 416574
URL: https://svnweb.freebsd.org/changeset/ports/416574

Log:
  sysutils/pick: 1.3.0 -> 1.4.0

  New features
  - Add a test suite (Anton Lindqvist, prahlad, Score_Under)
  - Add an -S option for disable sorting of choices (Calle Erlandsson)
  - Add UTF-8 support (Anton Lindqvist)
  - Add support for using the delete key and Ctrl-D interchangeably (prahlad)
  - Make use of pledge(1) on OpenBSD (Anton Lindqvist)

  Bug fixes
  - Fix compatibility issues with the Android NDK and the musl libc
    (Fredrik Fornwall)
  - Fix issues with newlines caused by colored input (Calle Erlandsson)
  - Fix standout rendering of the last line (Anton Lindqvist)
  - Refactoring and cleanup (Anton Lindqvist)

  Removed features
  - Remove altscreen condition if invoked from Vim (Anton Lindqvist)

  PR:		210108
  Submitted by:	Neel Chauhan <neel@neelc.org> (maintainer)

Changes:
  head/sysutils/pick/Makefile
  head/sysutils/pick/distinfo
  head/sysutils/pick/pkg-descr