Bug 210131 - Configuring base system
Summary: Configuring base system
Status: Closed DUPLICATE of bug 210141
Alias: None
Product: Base System
Classification: Unclassified
Component: conf (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-08 10:14 UTC by Sergey
Modified: 2016-06-08 14:19 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey 2016-06-08 10:14:15 UTC
Hello.
1.
I have following setting in /etc/src.conf:
WITHOUT_TCP_WRAPPERS=YES 
nontheless building sshd fails requireing tcpd.h file.

2.
Found out that file /usr/src/Makefile.inc1 contains following
# Needed for share/man
.if ${MK_MAN} != "no"
ITOOLS+=makewhatis
.endif

I have settings in /etc/src.conf:
#WITHOUT_MAN=YES
WITHOUT_MAN_UTILS=YES
which should build man pages but skip man utils (i use mandoc from ports)

but building releasi iso fails, requiring makewhatis file, i suppose it should be set as:
# Needed for share/man
.if ${MK_MAN_UTILS} != "no"
ITOOLS+=makewhatis
.endif

3.
Setting following variables in /etc/src.conf:
WITHOUT_AUDIT=YES
WITHOUT_PF=YES
WITHOUT_QUOTAS=YES
...
and many more,
doesn't remove auditd, auditdistd, pf, pflog, pfsync, quota ... etc. files from /etc/rc.d 

4.
Setting following variable in make.conf:
MODULES_OVERRIDE="drm2/drm2 drm2/i915kms"
works well (when you want to build some modules from subdirectory), but
WITHOUT_MODULES="usb/umass" would not work.

5. 
I'm not a developer and don't need dtrace in base, so i have to use following to rip it off from the system:

sed -E -i '' -e '/ (drti|lib(ctf|dtrace))/d' \
${SRCDIR}/cddl/lib/Makefile

sed -E -i '' -e '/ ctf.*/d' \
${SRCDIR}/cddl/usr.bin/Makefile

sed -E -i '' -e '/ (dtr(ace|uss)|p?lockstat)/d' \
${SRCDIR}/cddl/usr.sbin/Makefile

sed -E -i '' -e '/ dtrace/d' \
${SRCDIR}/share/Makefile

Could you please add WITHOUT_DTRACE to be able to disable it from the base.

6.
I have following settings in /etc/src.conf:
WITHOUT_AUDIT=YES
WITHOUT_BSNMP=YES
WITHOUT_TCP_WRAPPERS=YES 
WITHOUT_RADIUS_SUPPORT=YES

But appropriate libraies are not removed from the system, so I have to remove 'em manually:
sed -E -i '' -e '/ lib(auditd|begemot|bsm|tacplus|wrap)/d' \
${SRCDIR}/lib/Makefile

7.
Could you please add WITHOUT_ options for SAMBA, NFS, OPIE, TACACS, UGIDFW.
Now I have to rip them off manually from the system.
Comment 1 Brooks Davis freebsd_committer 2016-06-08 13:28:30 UTC
This is going to require quite a few different people to address.  You might have better luck with separate bug reports.
Comment 2 Sergey 2016-06-08 13:44:01 UTC
Hi Davis.
Could you please advise which of the topics should be separeted and under which component should I place 'em?
(note: most of the below are related to 10.X also)
Regards
Comment 3 Brooks Davis freebsd_committer 2016-06-08 14:06:57 UTC
1 and 2 look like outright bugs so should probably be separate.  3 could be one.  The others I'm less sure.  The more you combine unrelated areas, the less likely someone is going to tackle them unless they have the same problem.  Most of this should be pretty simple, but someone will have to do the work.
Comment 4 Sergey 2016-06-08 14:19:40 UTC

*** This bug has been marked as a duplicate of bug 210141 ***