Bug 210186 - comms/libcodec2: Update to 0.5.1
Summary: comms/libcodec2: Update to 0.5.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Diane Bruce
URL:
Keywords: needs-patch, needs-qa, patch
Depends on:
Blocks:
 
Reported: 2016-06-10 07:22 UTC by takefu
Modified: 2016-10-03 13:27 UTC (History)
2 users (show)

See Also:


Attachments
libcodec2-0.5.1.patch (12.08 KB, patch)
2016-06-10 07:22 UTC, takefu
takefu: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description takefu 2016-06-10 07:22:38 UTC
Created attachment 171258 [details]
libcodec2-0.5.1.patch

Add Options EXAMPLES TEST
Comment 1 Mathieu Arnold freebsd_committer 2016-06-10 09:58:46 UTC
Tests should not be an option but use TEST_DEPENDS and/or do-test.
Comment 2 VK freebsd_triage 2016-06-10 17:40:32 UTC
Thanks guys. Marking as needs-patch per Mathieu's comment. takefu@ please flag the revised patch with maintainer-approval+, since you're the maintainer, as that will make the PR appear in the "Maintainer Approved" saved search.
Comment 3 takefu 2016-09-12 08:12:32 UTC
Comment on attachment 171258 [details]
libcodec2-0.5.1.patch

Maintainer Approved
Comment 4 Diane Bruce freebsd_committer 2016-09-12 12:53:56 UTC
Category hamradio ports can be handled by hamradio@
Comment 5 takefu 2016-09-13 03:38:13 UTC
(In reply to Diane Bruce from comment #4)

audio/codec2 overlap with this.
I think we should delete one?
Comment 6 Diane Bruce freebsd_committer 2016-09-13 13:15:03 UTC
This does look like a duplicate of audio/codec2

comms/libcodec2 https://svnweb.freebsd.org/ports?view=revision&revision=409782
audio/codec2 https://svnweb.freebsd.org/ports?view=revision&revision=403762

looks like the comms/libcodec2 port is slightly older. We can't delete either port until we chase the dependancies and fix those. The testframe work and upgrade would then go with the port that remains.
Comment 7 commit-hook freebsd_committer 2016-09-28 15:02:29 UTC
A commit references this bug:

Author: db
Date: Wed Sep 28 15:01:47 UTC 2016
New revision: 422877
URL: https://svnweb.freebsd.org/changeset/ports/422877

Log:
  Update to 0.5.1
  Add some examples if requested.
  Add some test programs if requested.

  N.B. PR is actually against comms/libcodec2 which is a duplicate port.

  PR:		ports/210186
  Submitted by:	takefu@

Changes:
  head/audio/codec2/Makefile
  head/audio/codec2/distinfo
  head/audio/codec2/pkg-plist
Comment 8 Diane Bruce freebsd_committer 2016-09-28 15:04:16 UTC
I've updated the pre-existing audio/codec2 port with your diff. Should we delete this port? I don't see any other port referencing this one.
Comment 9 takefu 2016-10-03 01:50:06 UTC
(In reply to Diane Bruce from comment #8)
Please delete.
Comment 10 commit-hook freebsd_committer 2016-10-03 13:22:04 UTC
A commit references this bug:

Author: db
Date: Mon Oct  3 13:21:08 UTC 2016
New revision: 423191
URL: https://svnweb.freebsd.org/changeset/ports/423191

Log:
  Mark for removal in two months since port conflicts with prior existing
  audio/codec2	(Noted by Maintainer)
  Note conflict with codec2

  PR:		ports/210186
  Submitted by:	Maintainer
  Reported by:	takefu@
  Approved by:	takefu@

Changes:
  head/comms/libcodec2/Makefile
  head/comms/libcodec2/distinfo
_U  head/comms/libcodec2/pkg-descr
_U  head/comms/libcodec2/pkg-plist
Comment 11 commit-hook freebsd_committer 2016-10-03 13:24:06 UTC
A commit references this bug:

Author: db
Date: Mon Oct  3 13:23:11 UTC 2016
New revision: 423192
URL: https://svnweb.freebsd.org/changeset/ports/423192

Log:
  Note conflict with comms/libcodec2 which is already marked for removal
  No binary changes hence no PORTREVISION bump

  PR:		ports/210186
  Submitted by:	takefu@

Changes:
  head/audio/codec2/Makefile
Comment 12 Diane Bruce freebsd_committer 2016-10-03 13:26:58 UTC
I'll close this PR for now. Port is marked for removal in two months so we'll deal with it then. Thanks takefu@ for noticing the duplicate port!