Bug 210227 - make makeplist adds QT_ expansion in some pkg-plists
Summary: make makeplist adds QT_ expansion in some pkg-plists
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: kde
URL: https://reviews.freebsd.org/D8378
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-12 10:05 UTC by Kurt Jaeger
Modified: 2016-11-29 06:22 UTC (History)
4 users (show)

See Also:


Attachments
Hide QT_* plist-subs behind QT_DIST being defined (763 bytes, patch)
2016-06-12 12:30 UTC, Tobias Berner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Jaeger freebsd_committer 2016-06-12 10:05:21 UTC
For an example, look at 

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=210110
Comment 1 Tobias Berner 2016-06-12 12:30:30 UTC
Created attachment 171336 [details]
Hide QT_* plist-subs behind QT_DIST being defined

We could add an ".if define(QT_DIST)" around the QT_* PLIST_SUB exports in bsd.qt.mk. 

But the problem is, that some ports outside from qt itself probably also have legitimate use for these directories, and therefore can profit from those subs.
They would have to export them manually now by using the ${QT_FOO} variables themselves to the SUB.

So this patch needs an exp-run, followed by fixing [hopefully not] a lot of ports.
Comment 2 commit-hook freebsd_committer 2016-11-29 06:21:48 UTC
A commit references this bug:

Author: tcberner
Date: Tue Nov 29 06:20:42 UTC 2016
New revision: 427356
URL: https://svnweb.freebsd.org/changeset/ports/427356

Log:
  Stop exporting QT_BINDIR and QT_LIBDIR to PLIST_SUB.

  As at the moment QT_BINDIR and QT_LIBDIR are 'bin' respectively 'lib' depending
  on the Qt version these subs ended up at many wrong places in plists.

  So only export it if QT_DIST is set.

  PR:		210227
  Reviewed by:	mat, rakuco
  Approved by:	portmgr (mat), rakuco (mentor)
  Differential Revision:	https://reviews.freebsd.org/D8378

Changes:
  head/Mk/bsd.qt.mk
  head/cad/qelectrotech/pkg-plist
  head/devel/liblxqt/pkg-plist
  head/devel/libqtxdg/pkg-plist
  head/devel/qscintilla2/pkg-plist
  head/devel/qscintilla2-qt5/pkg-plist
  head/devel/qt4-libqtassistantclient/pkg-plist
  head/graphics/gle-graphics/pkg-plist
  head/math/vtk6/pkg-plist
  head/multimedia/dvbcut/pkg-plist
  head/multimedia/gstreamer-qt4/pkg-plist
  head/multimedia/phonon/pkg-plist
  head/multimedia/qt4-mobility/pkg-plist
  head/net-p2p/bitcoin/Makefile
  head/net-p2p/litecoin/Makefile
  head/sysutils/bareos-traymonitor/pkg-plist
  head/sysutils/qzeitgeist/pkg-plist
  head/x11-themes/qt5-style-plugins/pkg-plist