Bug 210354 - [patch] sysutils/hal - k3b, brasero does not find optical drive
Summary: [patch] sysutils/hal - k3b, brasero does not find optical drive
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-06-17 19:21 UTC by Ivan Klymenko
Modified: 2016-09-23 00:24 UTC (History)
7 users (show)

See Also:
kwm: maintainer-feedback+


Attachments
patch-hald_freebsd_hf-scsi.c (1.79 KB, patch)
2016-06-17 19:21 UTC, Ivan Klymenko
no flags Details | Diff
updated patch with portrevision (1.39 KB, patch)
2016-09-22 15:30 UTC, Steve Wills
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Klymenko 2016-06-17 19:21:32 UTC
Created attachment 171520 [details]
patch-hald_freebsd_hf-scsi.c

uname -a
FreeBSD nonamehost.local 11.0-ALPHA3 FreeBSD 11.0-ALPHA3 #1 r301964: Thu Jun 16 15:58:23 EEST 2016     ivan@nonamehost.local:/media/da0s1/obj/usr/src/sys/mk11  amd64

FreeBSD 11.0-ALPHA3 dont have /dev/acdX
Need be replaced patch file /usr/ports/sysutils/hal/files/patch-hald_freebsd_hf-scsi.c by the attached file to solved this problem.
Comment 1 Ben Woods freebsd_committer 2016-09-21 22:40:48 UTC
Ivan, did you mean to close this bug report? I notice you just referenced it in a mailing list post as a potential fix for someone's issue. Does that mean it is still a relevant bug, and should remain open?
https://lists.freebsd.org/pipermail/freebsd-ports/2016-September/104892.html
Comment 2 graham 2016-09-22 10:58:05 UTC
This patch worked for me in fixing k3b (11-stable amd64).

Why is it marked as "closed"? It still needs to be applied.

Thanks for the patch.
Comment 3 Ben Woods freebsd_committer 2016-09-22 11:08:03 UTC
Re-opened for consideration of adding path to sysutils/hal
Comment 4 Ivan Klymenko 2016-09-22 12:56:43 UTC
(In reply to Ben Woods from comment #1)

Yes - the problem is urgent, because it has not been fixed on the PR.
On the problem of no one pays attention - so nobody uses k3b and nobody is all unnecessary.
Now I, too, do not use FreeBSD - therefore closed all of its PR sarcastically "Works As Intended"


I'm tired of waiting.
Good luck!
Comment 5 Steve Wills freebsd_committer 2016-09-22 15:30:20 UTC
Created attachment 175067 [details]
updated patch with portrevision

Here's an updated diff, testing now, I've run into this issue too.
Comment 6 Koop Mast freebsd_committer 2016-09-22 17:46:29 UTC
If it works, go ahead and commit it.
Comment 7 Steve Wills freebsd_committer 2016-09-22 20:35:31 UTC
(In reply to Steve Wills from comment #5)
I believe I have the patch right, but in my testing it didn't help k3b. The device shows up fine in hal, kde shows a blank CDR showing up, but k3b still sees no device. Perhaps something else is required? Is it showing up in the KDE menu enough to prove the hal patch is correct at least?
Comment 8 graham 2016-09-22 21:44:27 UTC
(In reply to Steve Wills from comment #7)
I  think the fact that hal sees it proves that the bug is being fixed by the patch.

Have you done all the steps described in the k3b/pkg-message to fix permissions problems. Alternatively, try running k3b from the command line via sudo e.g. "sudo k3b". It works for me with those steps in place.

That said, on 11-stable, the hw.ata.atapi_dma sysctl oid that's described in those steps didn't exist for me. So I couldn't set it to 1. However, it didn't seem to matter.
Comment 9 Steve Wills freebsd_committer 2016-09-23 00:19:47 UTC
(In reply to graham from comment #8)
You're right, it was a permissions issue. I'll commit it.
Comment 10 commit-hook freebsd_committer 2016-09-23 00:21:15 UTC
A commit references this bug:

Author: swills
Date: Fri Sep 23 00:21:05 UTC 2016
New revision: 422642
URL: https://svnweb.freebsd.org/changeset/ports/422642

Log:
  sysutils/hal: fix cd support

  PR:		210354
  Submitted by:	Ivan Klymenko <fidaj@ukr.net>
  Approved by:	gnome@ (kwm)

Changes:
  head/sysutils/hal/Makefile
  head/sysutils/hal/files/patch-hald_freebsd_hf-scsi.c
Comment 11 Steve Wills freebsd_committer 2016-09-23 00:24:40 UTC
Committed, thanks!