Bug 210363 - databases/py-pymssql : Port broken due to FreeTDS upgrade
Summary: databases/py-pymssql : Port broken due to FreeTDS upgrade
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Dmitry Marakasov
URL: https://github.com/pymssql/pymssql/co...
Keywords: needs-qa, patch, regression
Depends on:
Blocks:
 
Reported: 2016-06-17 23:46 UTC by Henrik Hudson
Modified: 2016-12-26 11:32 UTC (History)
1 user (show)

See Also:
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henrik Hudson 2016-06-17 23:46:28 UTC
There is a build issue with the databases/py-pymssql 2.1.1 in ports due to FreeTDS moving to 1.00 . Upstream supposedly fixed this in 2.1.3, but having a different build issue with 2.1.3 and submitted a bug upstream.
Comment 1 Dmitry Marakasov freebsd_committer 2016-07-18 20:55:39 UTC
Maintainer CCd
Comment 2 Dmitry Marakasov freebsd_committer 2016-07-18 21:06:57 UTC
Sorry, didn't notice that submitter was maintainer. Anyway, I've backported upstream fix https://github.com/pymssql/pymssql/commit/ec46feae57b6c83cbee0615aef407a46ecfd650b, committing without approval as build fix. Please test whether it actually works.
Comment 3 commit-hook freebsd_committer 2016-07-18 21:07:46 UTC
A commit references this bug:

Author: amdmi3
Date: Mon Jul 18 21:06:53 UTC 2016
New revision: 418751
URL: https://svnweb.freebsd.org/changeset/ports/418751

Log:
  - Fix build after FreeTDS update by porting upstream commit ec46fea

  PR:		210363
  Reported by:	ports@thelanman.net (maintainer), pkg-fallout
  Approved by:	portmgr blanket

Changes:
  head/databases/py-pymssql/Makefile
  head/databases/py-pymssql/files/patch-__mssql.pyx
  head/databases/py-pymssql/files/patch-sqlfront.pxd