Bug 210425 - [Hyper-V]"smartctl -i /dev/da0" on FreeBSD 10.3 on Windows 2010 & 2016 server caused disk detached
Summary: [Hyper-V]"smartctl -i /dev/da0" on FreeBSD 10.3 on Windows 2010 & 2016 server...
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.3-RELEASE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-virtualization
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-06-21 03:21 UTC by Hongjiang
Modified: 2017-12-17 07:12 UTC (History)
3 users (show)

See Also:


Attachments
Screenshot for smartctl (52.79 KB, image/jpeg)
2016-06-21 03:21 UTC, Hongjiang
no flags Details
Fix the issue caused by inquiry (60.56 KB, patch)
2016-06-27 05:34 UTC, Hongjiang
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hongjiang 2016-06-21 03:21:57 UTC
Created attachment 171635 [details]
Screenshot for smartctl

The command “smartctl -a /dev/da0” can cause FreeBSD 10.2/10.3 system panic on windows 10 & 2016. But FreeBSD 10.2 on windows 2012 R2 does not panic.

The reproduce steps:
1) Install smartctl by “pkg install smartmontools-6.4.1”. You can search it by “pkg search smartmontools”
2) After installation, please execute “smartctl -a /dev/da0”. Then system panic and needs to reboot.

When this happens, I observed there are two issues:
1) There are “Standard Inquiry (36 bytes) failed” on putty console.
2) Storage disk is detached/destroyed.
Comment 1 Hongjiang 2016-06-27 05:34:58 UTC
Created attachment 171853 [details]
Fix the issue caused by inquiry

The patch can fix the issue on both 2012R2 and win2016 server
Comment 2 Hongjiang 2016-07-12 09:19:03 UTC
It has been fixed on head.
Comment 3 vali gholami 2017-12-17 07:12:38 UTC
MARKED AS SPAM