Bug 210461 - Realtek RTL8110SC 3 port Adapter doesn't work
Summary: Realtek RTL8110SC 3 port Adapter doesn't work
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.3-RELEASE
Hardware: i386 Any
: --- Affects Only Me
Assignee: freebsd-net mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-22 12:09 UTC by Massimo Giaimo
Modified: 2016-10-25 08:50 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Massimo Giaimo 2016-06-22 12:09:44 UTC
Hi Freebsd team, I'm a pfSense user. I  have a server with a Realtek 3 port network adapter (http://atacom.com/program/print_ipc_spec.cgi?Item_code=IMDB_JETA_1N_3R). This adapter work correctly in 2.1 pfSense Release (FreeBSD 8.3), but it is not recognized in 2.3 pfSense Release (FreeBSD 10.3-RELEASE-p3). Support for this device was deliberately eliminated?

I opened a post in pfSense forum and a user (kpa) told me this:

I'm almost 100% sure that:

A) The adapter was supported by the re(4) driver.

B) The reason the adapter no longer works is a regression in the re(4) driver and needs to be reported to FreeBSD devs working on the driver.

Any help will be appreciated!

Thank you!
Comment 1 Massimo Giaimo 2016-06-22 12:20:40 UTC
Link of pfSense forum post: https://forum.pfsense.org/index.php?topic=113954
Comment 2 Pyun YongHyeon freebsd_committer 2016-07-04 05:26:52 UTC
(In reply to Massimo Giaimo from comment #0)
AFAIK re(4) should support that controller.  If it is not the case
it might be a regression as the forum said.
Probably the first step to narrow down the issue is to boot with
FreeBSD 10.3-RELEASE and see the output of `pciconf -lcbv`.  If
there are entries for your controller in the output, the issue
would be in re(4).  If there are no entries, the issue would be in
pci(4).
Could you show us dmesg and `pciconf -lcbv` output on your box with
FreeBSD 10.3-RELEASE?