Bug 210542 - x11/xorg: Better documentation regarding 3D acceleration
Summary: x11/xorg: Better documentation regarding 3D acceleration
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-24 22:08 UTC by Yonas Yanfa
Modified: 2019-01-03 02:22 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yonas Yanfa 2016-06-24 22:08:30 UTC
There are two issues:


1. It's not very obvious that users need to add themselves to the "video" group for 3D acceleration to work.

2. The documentation states that users can add themselves to either the "video" or "wheel" group. In my case, I was already part of the wheel group, and I needed to specifically add myself to the video group to enable 3D acceleration (i915 on FreeBSD-11 CURRENT).


If it's not a bug that users need to specifically be part of the video group, then I think we need to enable 3D acceleration for anyone in the wheel group as well.
Comment 1 pete 2018-12-23 19:45:17 UTC
Hi there, this is a super old bug which I think can be closed now.

With the break-out of i915 and AMD Gpu into ports (drm-kmod) we document the requirement for a user to be a member of the "video" group.  I feel this is appropriate because I do not think this is a requirement for Nvidia drivers for example.
Comment 2 Niclas Zeising freebsd_committer 2019-01-03 02:22:14 UTC
Closing this.  Documentation has been improved, both in the handbook and in the wiki.  If there's issues with that, please re-open this or open a new PR.