Bug 210547 - games/cowsay: Update MASTER_SITES, Use GitHub
Summary: games/cowsay: Update MASTER_SITES, Use GitHub
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Matthew Seaman
URL:
Keywords: needs-patch, needs-qa
Depends on:
Blocks:
 
Reported: 2016-06-25 03:11 UTC by T M
Modified: 2016-06-26 15:14 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (lifanov)


Attachments
games/cowsay: 3.03 -> 3.04 (2.62 KB, patch)
2016-06-25 14:14 UTC, Nikolai Lifanov
lifanov: maintainer-approval+
Details | Diff
Update to 3.04, plist fixes, new WWW: (3.81 KB, patch)
2016-06-26 10:38 UTC, Matthew Seaman
matthew: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description T M 2016-06-25 03:11:13 UTC
I have made the code with full commit history available on GitHub, and tagged it for easy .tar.gz download.

https://github.com/tnalpgge/rank-amateur-cowsay

https://github.com/tnalpgge/rank-amateur-cowsay/archive/cowsay-3.04.tar.gz

Future releases, if any, are likely to come from some other repository on GitHub.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2016-06-25 03:29:19 UTC
@Tony, 

- Is there an issue with the existing DISTFILES / MASTER_SITES?
- Is cowsay-3.0.4 the correct repository?

Will leave it to maintainer to determine whether to accept the change request or not
Comment 2 T M 2016-06-25 03:40:48 UTC
The first link is to the repository; the second is to the source download.  I verified the correctness of both of them myself.

I know that this can't really be proven based on what some stranger says in a bug report, but I wrote cowsay long ago.  Based on mails I've received over the years, and in the last few months in particular, I've decided to make it easier for those who would wish to package cowsay for their operating system, at the very least.  So today I set up the repository in GitHub and applied tags so that a source distribution could be downloaded from some persistent, well-known location where the code is actually hosted.

Version 3.04 updates the licensing terms but offers no changes in functionality.
Comment 3 Nikolai Lifanov 2016-06-25 14:11:32 UTC
Hi! I believe your authorship. Complete CVS history is proof enough for me.
Thank you for uploading the software. I was mirroring the distfile because
the original upstream went away. Can you please clarify if the license is
GPLv3 or "GPLv3 or later"?
Comment 4 Nikolai Lifanov 2016-06-25 14:14:26 UTC
Created attachment 171789 [details]
games/cowsay: 3.03 -> 3.04

o update to 3.04
o add license
o switch upstream to GitHub
o regenerate patch with "make makepatch"

Please wait for response whether to make this GPLv3 or GPLv3+.
Comment 5 Nikolai Lifanov 2016-06-25 14:16:29 UTC
Note: I confirmed tarball contents and functionality.

One more for the changelog:
o unsilence INSTALL commands
Comment 6 T M 2016-06-25 16:35:33 UTC
"GPLv3 or later" is acceptable.
Comment 7 Matthew Seaman freebsd_committer 2016-06-26 10:16:40 UTC
There were a number of files missed from pkg-plist:

:% diff -u pkg-plist pkg-plist.n
--- pkg-plist	2015-01-16 21:15:24.590831144 +0000
+++ pkg-plist.n	2016-06-26 11:13:54.987157155 +0100
@@ -2,7 +2,15 @@
 bin/cowthink
 man/man1/cowsay.1.gz
 man/man1/cowthink.1.gz
+share/cows/DragonAndCow.pm
+share/cows/Example.pm
+share/cows/Frogs.pm
+share/cows/MechAndCow.pm
+share/cows/Stegosaurus.pm
+share/cows/TextBalloon.pm
+share/cows/TuxStab.pm
 share/cows/beavis.zen.cow
+share/cows/blowfish.cow
 share/cows/bong.cow
 share/cows/box.cow
 share/cows/bud-frogs.cow
@@ -46,8 +54,8 @@
 share/cows/three-eyes.cow
 share/cows/turkey.cow
 share/cows/turtle.cow
-share/cows/tux.cow
 share/cows/tux-stab.cow
+share/cows/tux.cow
 share/cows/udder.cow
 share/cows/vader-koala.cow
 share/cows/vader.cow

Fixed that for you.
Comment 8 Matthew Seaman freebsd_committer 2016-06-26 10:34:42 UTC
Also:

Avoid using GH_TAGNAME where you can.  Here,it's better to use DISTVERSIONPREFIX=cowsay-

Plus the WWW line in pkg-descr is a dead link: there doesn't seem to be a websever running on that host any more:

% curl -v http://www.nog.net/~tony/warez/cowsay.shtml
*   Trying 50.193.2.146...
* connect to 50.193.2.146 port 80 failed: No route to host
* Failed to connect to www.nog.net port 80: No route to host
* Closing connection 0
curl: (7) Failed to connect to www.nog.net port 80: No route to host

Let's use the github site instead.

I'll upload a new diff for approval
Comment 9 Matthew Seaman freebsd_committer 2016-06-26 10:38:04 UTC
Created attachment 171813 [details]
Update to 3.04, plist fixes, new WWW:

poudriere testport builds OK on 9.3-i386, 9.3-amd64, 10.1-i386, 10.1-amd64
Comment 10 Nikolai Lifanov 2016-06-26 14:32:49 UTC
Thanks for the improvements! It looks good to me as-is.
Can you change GPLv3 to GPLv3+ when committing please?
Comment 11 Nikolai Lifanov 2016-06-26 14:34:13 UTC
Comment on attachment 171813 [details]
Update to 3.04, plist fixes, new WWW:

Bugzilla is being weird about the flag. I approve this patch.
Comment 12 commit-hook freebsd_committer 2016-06-26 15:13:57 UTC
A commit references this bug:

Author: matthew
Date: Sun Jun 26 15:13:22 UTC 2016
New revision: 417530
URL: https://svnweb.freebsd.org/changeset/ports/417530

Log:
  Update to 3.04

    - switch to GitHub.  This is the account belonging to the original
      author of cowsay, who submitted the PR.

  PR:		210547
  Submitted by:	tony+freebsd@nog.net (author)
  Approved by:	lifanov@mail.lifanov.com (maintainer)

Changes:
  head/games/cowsay/Makefile
  head/games/cowsay/distinfo
  head/games/cowsay/files/patch-cowsay
  head/games/cowsay/pkg-descr
  head/games/cowsay/pkg-plist
Comment 13 Matthew Seaman freebsd_committer 2016-06-26 15:14:15 UTC
Committed, thanks!