Bug 210551 - sysutils/screen provide a warning that 4.4 can't reattach to 4.3 sessions
Summary: sysutils/screen provide a warning that 4.4 can't reattach to 4.3 sessions
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Cy Schubert
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-25 07:52 UTC by Derek Schrock
Modified: 2016-06-26 06:01 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (cy)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Derek Schrock 2016-06-25 07:52:00 UTC
With screen 4.4 any session that was created with <4.4 can't be reattached with 4.4.  https://lists.gnu.org/archive/html/screen-users/2016-06/msg00014.html

Should a warning be printed via pkg-message or during pre-install with and option to cnt-c after X seconds to allow the user to stop the install to handle any 4.3 session cleanup before installing 4.4?
Comment 1 commit-hook freebsd_committer 2016-06-26 06:01:11 UTC
A commit references this bug:

Author: cy
Date: Sun Jun 26 06:00:42 UTC 2016
New revision: 417511
URL: https://svnweb.freebsd.org/changeset/ports/417511

Log:
  Add a pkg-message note about a fix to the screen message structure
  field responsible for $TERM handling. It is impossible to reattach
  to older versions.

  See https://lists.gnu.org/archive/html/screen-users/2016-06/msg00014.html.

  PR:		210551

Changes:
  head/sysutils/screen/Makefile
  head/sysutils/screen/pkg-message