Bug 210565 - usr.bin/lastcomm failed kyua status for 11.0 -r302180 (only tested on rpi2 with -mcpu=cortex-a7 in use)
Summary: usr.bin/lastcomm failed kyua status for 11.0 -r302180 (only tested on rpi2 wi...
Status: Closed DUPLICATE of bug 204154
Alias: None
Product: Base System
Classification: Unclassified
Component: arm (show other bugs)
Version: CURRENT
Hardware: arm Any
: --- Affects Only Me
Assignee: freebsd-arm (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-25 09:43 UTC by Mark Millard
Modified: 2016-06-25 15:25 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Millard 2016-06-25 09:43:13 UTC
[The ". . ."s are omitted Metadata lines or other omitted blocks of text.]
(only tested on rpi2 with -mcpu=cortex-a7 in use)

kyua report --results-filter failed --results-file /usr/tests --verbose

reports for usr.bin/lastcomm:

===> usr.bin/lastcomm/legacy_test:main
Result: failed: 4 tests of 6 failed
Duration: 0.139s
. . .
Standard output:
1..6
not ok 1
not ok 2
not ok 3
not ok 4
ok 5
ok 6
 
Standard error:
cat: /usr/tests/usr.bin/lastcomm/v1-arm-acct.in: No such file or directory
cat: /usr/tests/usr.bin/lastcomm/v2-arm-acct.in: No such file or directory
cat: /usr/tests/usr.bin/lastcomm/v2-arm.out: No such file or directory
cat: /usr/tests/usr.bin/lastcomm/v1-arm.out: No such file or directory
lastcomm: could not open /usr/tests/usr.bin/lastcomm/v1-arm-acct.in: No such file or directory
diff: /usr/tests/usr.bin/lastcomm/v1-arm.out: No such file or directory
/usr/tests/usr.bin/lastcomm/legacy_test: cannot open /usr/tests/usr.bin/lastcomm/v1-arm-acct.in: No such file or directory
diff: /usr/tests/usr.bin/lastcomm/v1-arm.out: No such file or directory
lastcomm: could not open /usr/tests/usr.bin/lastcomm/v2-arm-acct.in: No such file or directory
diff: /usr/tests/usr.bin/lastcomm/v2-arm.out: No such file or directory
/usr/tests/usr.bin/lastcomm/legacy_test: cannot open /usr/tests/usr.bin/lastcomm/v2-arm-acct.in: No such file or directory
diff: /usr/tests/usr.bin/lastcomm/v2-arm.out: No such file or directory
Comment 1 Alan Somers freebsd_committer 2016-06-25 15:07:30 UTC
Looks like someone needs to generate golden files for arm, or at least restrict the architectures where the test can run.
Comment 2 Alan Somers freebsd_committer 2016-06-25 15:25:47 UTC

*** This bug has been marked as a duplicate of bug 204154 ***