Bug 210572 - Installer does not fully identify discs in multiple-disc system
Summary: Installer does not fully identify discs in multiple-disc system
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 10.3-STABLE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-25 14:27 UTC by MMacD
Modified: 2016-06-28 04:23 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MMacD 2016-06-25 14:27:58 UTC
This is a significant human-factors issue.

Installing 10.3 to a system with 4 motherboard SATA ports and a re-flashed M1015 8-port SAS controller card, all fully populated with disks, I realised that the disc identifier offered is the *model number*, which is not at all useful when there are several discs of the same model installed.  Since the bios and the os don't necessarily agree on the device ordering, I had no way of reliably picking out my intended install disc.  I had to shut down, disconnect the data cables from every disc but the ones to the dvd drive and the install disc, and then restart.

If the installer showed the model number, size, AND the existing partitions, the problem I had would not have arisen.
Comment 1 Nathan Whitehorn freebsd_committer 2016-06-27 01:14:03 UTC
It does show them, in detail, if you enter the partition editor.
Comment 2 MMacD 2016-06-27 20:31:50 UTC
I always take option 1, the guided MBR thing. Which only shows the useless model numbers.  

I do that in part that's because my field is human factors, so I do what new people do because that's where the problems show up quickest.  The people who wrote the installer are experts, and it's pretty much impossible without a lot of training for an expert to remember how it was to be a novice.  So they do things that seem perfectly sensible to them, but which confuse and derail anyone new.  (For broadly the same reason, whenever I'd do QA, I'd always go after the boundary conditions because I'd invariably find bugs, which would enrage the dev and product managers.  But I was the program manager so they didn't say too much)

Would it really be hard to migrate the information from the part table editor?  It doesn't seem like it would be - the code already exists and it's not as tho the installer has to fit in rom - but I've not looked at the code.

It really is a bug, if you want people to be able to reliably use that option even under boundary conditions.
Comment 3 Nathan Whitehorn freebsd_committer 2016-06-28 04:23:26 UTC
(In reply to MMacD from comment #2)

There is no technical issue in showing anything we like. The issue is what to show: if you print the whole partition table, you just end up with the normal partition editor again and don't really solve anything. I can't think of something less than that that covers all the cases, however.

In general, I would also imagine that most people going through the automatic mode only have one hard drive anyway.