Bug 210574 - cad/openvsp: Update to 3.7.2
Summary: cad/openvsp: Update to 3.7.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Thomas Zander
URL:
Keywords: easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2016-06-25 16:00 UTC by Fernando Apesteguía
Modified: 2016-06-26 12:36 UTC (History)
1 user (show)

See Also:


Attachments
Patch to the ports tree (1.39 KB, patch)
2016-06-25 16:00 UTC, Fernando Apesteguía
fernape: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Fernando Apesteguía freebsd_committer 2016-06-25 16:00:37 UTC
Created attachment 171792 [details]
Patch to the ports tree

The attached patch updates cad/openvsp to version 3.7.2.

3.7.0 was released a couple of days ago but before my poudriere tests were finished (how I miss redports.org!) two bugfix releases were out.

From the changelogs:

Features:
 - Wave drag estimation by area distribution and Eminton Lord calculation
 - Variable presets for saving model state
Bug Fixes:
 - Fix crash caused by reading file without VarPresets field.
 - Fix crash when deleting empty var presets group

Link to poudriere logs for {10.1,10.3}{i386,amd64}:

https://drive.google.com/open?id=0ByDxWLRMi928RVNqYU9vcVpRSHM

The port doesn't build on FreeBSD < 10.x due to the lack of some mathematical functions.

Note: the logs will disappear at some point after the commit.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2016-06-25 16:05:47 UTC
Thanks for your submission Fernando

For future issues, there's no need to include QA logs as links or attachments, just mention they have been run and passed as follows:

- portlint: OK (looks fine.)
- testport: OK (poudriere: <versions>, <archs> tested)
Comment 2 Fernando Apesteguía freebsd_committer 2016-06-25 16:43:15 UTC
(In reply to Kubilay Kocak from comment #1)
I will do.

BTW portlint at this point is not ok. It complains about:

- All the dependencies since I removed ${PORTSDIR}
- The TIMESTAMP line in distinfo

Any plans to update portlint?

Cheers.
Comment 3 Thomas Zander freebsd_committer 2016-06-26 08:49:47 UTC
The linking in this port looks a bit strange.

1) There is this during build:

====> Running Q/A tests (stage-qa)
Error: /usr/local/bin/vsp is linked to /usr/local/lib/libc++.so.1 from devel/libc++ but it is not declared as a dependency
Warning: you need LIB_DEPENDS+=libc++.so:devel/libc++
====> Checking for pkg-plist issues (check-plist)

After removal of devel/libc++, would this port still work at runtime?


2) The port uses openmp, but there is no USES=compiler:openmp. Is this due to the USES=compiler:gcc-c++11-lib since gcc happens to support openmp?
Comment 4 Fernando Apesteguía freebsd_committer 2016-06-26 09:21:59 UTC
(In reply to Thomas Zander from comment #3)

1)

I opened a discussion here: http://www.mail-archive.com/freebsd-ports@freebsd.org/msg69326.html

libc++ is in base in 10 and bigger (the port doesn't compile in anything < 10.x). I think the output of the script is kind of spurious since the port links agains the libc++ in base just fine.

2) 
Yes. The port doesn't compile with clang yet. But if you feel it'd be better to add that clause for the sake of completeness or clarity I can do it.
Comment 5 commit-hook freebsd_committer 2016-06-26 12:33:41 UTC
A commit references this bug:

Author: riggs
Date: Sun Jun 26 12:33:28 UTC 2016
New revision: 417520
URL: https://svnweb.freebsd.org/changeset/ports/417520

Log:
  Update to upstream version 3.7.2

  Detailed maintainer log:
  Features:
   - Wave drag estimation by area distribution and Eminton Lord calculation
   - Variable presets for saving model state
  Bug Fixes:
   - Fix crash caused by reading file without VarPresets field.
   - Fix crash when deleting empty var presets group

  While on it:
  - Pet portlint

  PR:		210574
  Submitted by:	fernando.apesteguia@gmail.com (maintainer)

Changes:
  head/cad/openvsp/Makefile
  head/cad/openvsp/distinfo