Bug 210589 - databases/py-sqlalchemy-migrate: Update to 0.10.0
Summary: databases/py-sqlalchemy-migrate: Update to 0.10.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords: needs-qa, patch, regression
Depends on:
Blocks:
 
Reported: 2016-06-26 14:31 UTC by Kurt Jaeger
Modified: 2016-10-09 16:17 UTC (History)
2 users (show)

See Also:
pi: maintainer-feedback+
koobs: maintainer-feedback+


Attachments
patch (1.59 KB, patch)
2016-06-26 14:31 UTC, Kurt Jaeger
no flags Details | Diff
patch-v2 (1.65 KB, patch)
2016-06-26 14:40 UTC, Kurt Jaeger
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Jaeger freebsd_committer 2016-06-26 14:31:09 UTC
Created attachment 171822 [details]
patch

portlint is fine.

poudriere still needs some work
Comment 1 Kurt Jaeger freebsd_committer 2016-06-26 14:40:58 UTC
Created attachment 171823 [details]
patch-v2

this builds fine in poudriere on 10.3a+i, 9.3a. It builds on 11 outside of poudriere. Why does libreoffice take so long to build on 11 ? 9 hours ? This blocks my testjail for 11a 8-}
Comment 2 Li-Wen Hsu freebsd_committer 2016-06-27 08:36:51 UTC
Thanks for the patch, and sorry that I cannot verify this very soon (in two weeks).  You're welcomed to commit the update you think it's right, and please feel free to take over the maintainership.
Comment 3 Kurt Jaeger freebsd_committer 2016-08-03 16:21:53 UTC
Committed, thanks.
Comment 4 commit-hook freebsd_committer 2016-08-03 16:22:10 UTC
A commit references this bug:

Author: pi
Date: Wed Aug  3 16:21:44 UTC 2016
New revision: 419532
URL: https://svnweb.freebsd.org/changeset/ports/419532

Log:
  databases/py-sqlalchemy-migrate: 0.7.2 -> 0.10.0

  PR:		210589
  Changes:	https://github.com/openstack/sqlalchemy-migrate/releases
  Approved by:	lwhsu

Changes:
  head/databases/py-sqlalchemy-migrate/Makefile
  head/databases/py-sqlalchemy-migrate/distinfo
  head/databases/py-sqlalchemy-migrate/pkg-descr
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2016-08-05 08:51:14 UTC
Re-opening due to regression post commit:

r419532 [1] caused ports that depend on sqlalchemy07 and sqlalchemy-migrate (at least buildbot) to fail because py-sqlalchemy-migrate pulls in py-sqlalchemy10 which conflicts with py-sqlalchemy07.

http://beefy10.nyi.freebsd.org/data/110i386-default/419570/logs/buildbot-0.8.12_1.log

[1] http://svnweb.freebsd.org/changeset/ports/419532

There needs to be 07 and 10 versions of -migrate unless all ports depending on 07 can be upgraded to use 10.

More precisely there needs to be an equal number of *-migrate ports as there are sqlalchemy ports supported at all times, unless the latter can, and have been confirmed and tested to work with multiple versions of *-migrate.

Can you revert this commit until a proper root-cause / fix is identified please
Comment 6 Kurt Jaeger freebsd_committer 2016-08-06 03:18:35 UTC
If you change the dependency from sqlalchemy07 to sqlalchemy10, does buildbot still work ?
Comment 7 Kurt Jaeger freebsd_committer 2016-08-06 07:02:32 UTC
btw, testbuilds for buildbot with sqlalchemy10 as dependency are fine.
Comment 8 Kubilay Kocak freebsd_committer freebsd_triage 2016-08-06 08:33:11 UTC
The only tests I would consider satisfying would be run time test suites (which buildbot does have).

Having said that, there's 15 ports that currently RUN_DEPEND on sqlalchemy07, and switching their dependencies forward and testing properly will take longer than we want to have these ports remain broken.

In the meantime we need a resolution quickly, and since reverting the change will also mean bumping PORTEPOCH (which lwhsu doesn't like), perhaps an alternative is creation of a py-sqlalchemy07-migrate and moving the current dependents over to that.

Either way, we need to resolve this asap, either with an alternative, or failing one being viable, a revert and PORTEPOCH++
Comment 9 Kurt Jaeger freebsd_committer 2016-08-06 08:52:25 UTC
Ran 3032 tests in 17.243s

FAILED (skips=27, errors=2, successes=3003)

In the normal case, do all tests work ?
Comment 10 Kurt Jaeger freebsd_committer 2016-08-07 08:03:37 UTC
(In reply to Kurt Jaeger from comment #9)

A test with the previous setup:

Ran 3032 tests in 37.556s

FAILED (skips=27, errors=2, successes=3003)

so updating buildbot to use py-sqlalchemy10 does not change the outcome of the tests ?
Comment 11 Li-Wen Hsu freebsd_committer 2016-08-07 08:13:47 UTC
(In reply to Kurt Jaeger from comment #10)

Seems so, updating buildbot's dependency doesn't introduce more regressions.
And there are just few ports depend on py-sqlalchemy-migrate:

$ grep sqlalchemy-migrate /usr/ports/INDEX-10 | awk -F'|' '{ print $2}'
/usr/ports/databases/py-sqlalchemy-migrate
/usr/ports/devel/buildbot
/usr/ports/multimedia/py-openlp
/usr/ports/www/py-imdbpy

Is it possible for you to check others?  If the results are the same, we can update dependency of these ports.
Comment 12 Kurt Jaeger freebsd_committer 2016-08-07 09:30:37 UTC
Yes, I'm working to find fixes for the others. I'm trying to avoid the revert...
Comment 13 Li-Wen Hsu freebsd_committer 2016-08-07 09:38:37 UTC
(In reply to Kurt Jaeger from comment #12)

Thanks for the help, if that takes some more time, we can just add py-sqlalchemy-migrate07 in the mean time. That makes ports tree consistent.
Comment 14 commit-hook freebsd_committer 2016-08-07 10:08:02 UTC
A commit references this bug:

Author: pi
Date: Sun Aug  7 10:07:53 UTC 2016
New revision: 419767
URL: https://svnweb.freebsd.org/changeset/ports/419767

Log:
  www/py-imdbpy: chase sqlalchemy dependencies

  PR:		210589

Changes:
  head/www/py-imdbpy/Makefile
Comment 15 Kubilay Kocak freebsd_committer freebsd_triage 2016-08-07 11:37:38 UTC
@Kurt I'll switch buildbot over to sqlalchemy10 shortly
Comment 16 commit-hook freebsd_committer 2016-08-07 14:07:19 UTC
A commit references this bug:

Author: koobs
Date: Sun Aug  7 14:06:57 UTC 2016
New revision: 419777
URL: https://svnweb.freebsd.org/changeset/ports/419777

Log:
  devel/buildbot: Update sqlalchemy RUN_DEPENDS

  r419532 [1] caused ports that depend on sqlalchemy07 and
  sqlalchemy-migrate (at least buildbot) to fail because
  py-sqlalchemy-migrate pulls in py-sqlalchemy10 which conflicts with
  py-sqlalchemy07.

  Update the sqlalchemy dependency from 0.7.x to 1.0.x after QA
  testing for regressions @ runtime using the buildbot test suite.

  [1] http://svnweb.freebsd.org/changeset/ports/419532

  PR:		210589
  Reported by:	pkg-fallout
  Tested by:	pi
  MFH:		2016Q3

Changes:
  head/devel/buildbot/Makefile
Comment 17 commit-hook freebsd_committer 2016-08-07 14:11:21 UTC
A commit references this bug:

Author: koobs
Date: Sun Aug  7 14:10:19 UTC 2016
New revision: 419778
URL: https://svnweb.freebsd.org/changeset/ports/419778

Log:
  MFH: r419777

  devel/buildbot: Update sqlalchemy RUN_DEPENDS

  r419532 [1] caused ports that depend on sqlalchemy07 and
  sqlalchemy-migrate (at least buildbot) to fail because
  py-sqlalchemy-migrate pulls in py-sqlalchemy10 which conflicts with
  py-sqlalchemy07.

  Update the sqlalchemy dependency from 0.7.x to 1.0.x after QA
  testing for regressions @ runtime using the buildbot test suite.

  [1] http://svnweb.freebsd.org/changeset/ports/419532

  PR:		210589
  Reported by:	pkg-fallout
  Tested by:	pi

  Approved by:	ports-secteam (blanket)

Changes:
_U  branches/2016Q3/
  branches/2016Q3/devel/buildbot/Makefile
Comment 18 Kurt Jaeger freebsd_committer 2016-08-07 20:31:10 UTC
(In reply to Li-Wen Hsu from comment #11)
multimedia/py-openlp has been fixed by the maintainer
Comment 19 Kurt Jaeger freebsd_committer 2016-08-12 17:21:53 UTC
So, any ports left that need fixing ? I'll close this PR in 24h, if no other
ports come up.
Comment 20 Kubilay Kocak freebsd_committer freebsd_triage 2016-08-12 17:30:05 UTC
I'll wait for the next pkg-fallout run, unless there's somewhere public? to see if the last run was successful for the previously failing ports
Comment 21 Kurt Jaeger freebsd_committer 2016-08-22 19:55:52 UTC
devel/buildbot fails in quarterly, because the update was not MFHed.

TODO: think about if a MFH would be useful -- I think then other
updates would need MFH, which is probably excessive. Hm...
Comment 22 Kurt Jaeger freebsd_committer 2016-10-09 16:17:45 UTC
Next quarterly is done, so probably all fine. If not, please create a new PR.