Bug 210627 - sysutils/py-salt: Fix cron.file (upstream issue #34094)
Summary: sysutils/py-salt: Fix cron.file (upstream issue #34094)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jason Unovitch
URL: https://github.com/saltstack/salt/iss...
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-06-27 14:21 UTC by Andres Montalban
Modified: 2016-07-13 01:58 UTC (History)
3 users (show)

See Also:
christer.edwards: maintainer-feedback+
junovitch: merge-quarterly+


Attachments
Patch to fix cron.file in 2016.3.1 (1.47 KB, patch)
2016-06-27 14:21 UTC, Andres Montalban
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andres Montalban 2016-06-27 14:21:55 UTC
Created attachment 171868 [details]
Patch to fix cron.file in 2016.3.1

Hi,

This is a patch to fix saltstack/salt#34094 in 2016.3.1

[1] https://github.com/saltstack/salt/issues/34094

Thanks!
Comment 1 commit-hook freebsd_committer 2016-07-13 01:54:25 UTC
A commit references this bug:

Author: junovitch
Date: Wed Jul 13 01:53:46 UTC 2016
New revision: 418455
URL: https://svnweb.freebsd.org/changeset/ports/418455

Log:
  sysutils/py-salt: add patches to handle runtime regressions in 2016.3.x

  Fixes cron.file from upstream issue #34094/#34095 [1].  This will be in
  2016.3.2.
  - https://github.com/saltstack/salt/issues/34094
  - https://github.com/saltstack/salt/pull/34095

  Restore patch for upstream issue #33608. This was patched in 2016.3.0 but
  removed in the maintainer update to 2016.3.1 in r417508. However the patch
  has yet to be merged upstream. [2]
  - https://github.com/saltstack/salt/issues/33608

  PR:		210627 [1], 210395 [2]
  Reported by:	Andres Montalban <amontalban@gmail.com>
  Approved by:	Christer Edwards <christer.edwards@gmail.com> (maintainer)
  MFH:		2016Q3

Changes:
  head/sysutils/py-salt/Makefile
  head/sysutils/py-salt/files/patch-salt_grains_core.py
  head/sysutils/py-salt/files/patch-salt_states_cron.py
Comment 2 commit-hook freebsd_committer 2016-07-13 01:55:29 UTC
A commit references this bug:

Author: junovitch
Date: Wed Jul 13 01:54:29 UTC 2016
New revision: 418456
URL: https://svnweb.freebsd.org/changeset/ports/418456

Log:
  MFH: r418455

  sysutils/py-salt: add patches to handle runtime regressions in 2016.3.x

  Fixes cron.file from upstream issue #34094/#34095 [1].  This will be in
  2016.3.2.
  - https://github.com/saltstack/salt/issues/34094
  - https://github.com/saltstack/salt/pull/34095

  Restore patch for upstream issue #33608. This was patched in 2016.3.0 but
  removed in the maintainer update to 2016.3.1 in r417508. However the patch
  has yet to be merged upstream. [2]
  - https://github.com/saltstack/salt/issues/33608

  PR:		210627 [1], 210395 [2]
  Reported by:	Andres Montalban <amontalban@gmail.com>
  Approved by:	Christer Edwards <christer.edwards@gmail.com> (maintainer)
  Approved by:	ports-secteam (with hat)

Changes:
_U  branches/2016Q3/
  branches/2016Q3/sysutils/py-salt/Makefile
  branches/2016Q3/sysutils/py-salt/files/patch-salt_grains_core.py
  branches/2016Q3/sysutils/py-salt/files/patch-salt_states_cron.py
Comment 3 Jason Unovitch freebsd_committer 2016-07-13 01:58:41 UTC
Andres, thanks for reporting this issue by the way. The patch is in place and MFH'd since we updated to 2016.3.1 just before the 2016Q3 cut and this is a clear regression from the 2016.3.x series.