Bug 210718 - mail/geary: update to 0.12.0
Summary: mail/geary: update to 0.12.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gnome mailing list
URL:
Keywords: patch, patch-ready
: 223790 (view as bug list)
Depends on:
Blocks: 221941
  Show dependency treegraph
 
Reported: 2016-06-30 06:02 UTC by Zsolt Udvari
Modified: 2018-01-24 17:20 UTC (History)
5 users (show)

See Also:
truckman: maintainer-feedback+


Attachments
patch (5.45 KB, patch)
2016-06-30 06:02 UTC, Zsolt Udvari
no flags Details | Diff
geary-0.12.0.patch (9.05 KB, patch)
2017-10-04 22:51 UTC, Greg V
no flags Details | Diff
geary-0.12.0.diff (7.85 KB, patch)
2017-10-28 15:21 UTC, Carlos J. Puga Medina
cpm: maintainer-approval? (gnome)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zsolt Udvari 2016-06-30 06:02:20 UTC
Created attachment 171967 [details]
patch

- update to 0.11.1
- add license
- use cmake:outsource
- message about sqlite3

Poudriere log: http://freebsd.uzsolt.hu/logs/geary/geary-0.11.1.log
News:
https://download.gnome.org/sources/geary/0.11/geary-0.11.0.news
https://download.gnome.org/sources/geary/0.11/geary-0.11.1.news
Comment 1 Greg V 2017-10-04 22:51:41 UTC
Created attachment 186913 [details]
geary-0.12.0.patch

Thanks! Applied this patch (after some fixes since it got somewhat old), further upgraded to 0.12.0, here's the result. Builds fine with vala 0.38.1 on 12-CURRENT.
Comment 2 Carlos J. Puga Medina freebsd_committer 2017-10-14 12:23:45 UTC
Comment on attachment 186913 [details]
geary-0.12.0.patch

>diff --git c/mail/geary/Makefile i/mail/geary/Makefile
>index ea162f75f24d..ec82db454f17 100644
>--- c/mail/geary/Makefile
>+++ i/mail/geary/Makefile
>@@ -3,7 +3,7 @@
> #   $MCom: ports/trunk/mail/geary/Makefile 20050 2014-11-10 09:22:41Z gusi $
> 
> PORTNAME=	geary
>-PORTVERSION=	0.10.0
>+PORTVERSION=	0.12.0
> CATEGORIES=	mail gnome
> MASTER_SITES=	GNOME
> DIST_SUBDIR=	gnome3
>@@ -11,29 +11,41 @@ DIST_SUBDIR=	gnome3
> MAINTAINER=	gnome@FreeBSD.org
> COMMENT=	Mail client for GNOME 3
> 
>-BUILD_DEPENDS=	vapigen:lang/vala \
>-		bash:shells/bash
>+LICENSE=	LGPL21 CCA3 PORTER
>+LICENSE_COMB=	dual
>+LICENSE_FILE_CCA3=	${WRKSRC}/COPYING.icons
>+LICENSE_NAME_CCA3=	Creative Common Attribution 3.0 Unported License
>+LICENSE_PERMS_CCA3=	dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
>+LICENSE_FILE_PORTER=	${WRKSRC}/COPYING.snowball
>+LICENSE_NAME_PORTER=	Martin Porter, Richard Boulton
>+LICENSE_PERMS_PORTER=	dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
>+

LICENSE block should be defined as follows

+LICENSE=	BSD2CLAUSE CC-BY-3.0 LGPL21
+LICENSE_COMB=	multi


>+BUILD_DEPENDS=	vapigen:lang/vala
> LIB_DEPENDS=	libgmime-2.6.so:mail/gmime26 \
>-		libwebkitgtk-3.0.so:www/webkit-gtk3 \
>+		libwebkit2gtk-4.0.so:www/webkit2-gtk3 \
>+		libjavascriptcoregtk-4.0.so:www/webkit2-gtk3 \
>+		libcanberra.so:audio/libcanberra \
> 		libcanberra-gtk3.so:audio/libcanberra-gtk3 \
> 		libnotify.so:devel/libnotify \
> 		libgee-0.8.so:devel/libgee \
>-		libgcr-3.so:security/gcr
>+		libgcr-3.so:security/gcr \
>+		libsecret-1.so:security/libsecret \
>+		libp11-kit.so:security/p11-kit \
>+		libsoup-2.4.so:devel/libsoup \
>+		libenchant.so:textproc/enchant
> 
>-USES=		cmake desktop-file-utils gettext \
>-		libtool pkgconfig shebangfix tar:xz
>-USE_GNOME=	gnomedocutils gnomeprefix gtk30 intlhack
>+USES=		cmake:outsource desktop-file-utils gettext \
>+		libtool pkgconfig shebangfix sqlite tar:xz
>+USE_GNOME=	cairo gnomedocutils gnomeprefix gtk30 intlhack introspection
> SHEBANG_FILES=	desktop/geary-attach
> USE_LDCONFIG=	yes
> INSTALLS_ICONS=	yes
> CPPFLAGS+=	-I${LOCALBASE}/include
> LDFLAGS+=	-L${LOCALBASE}/lib
>-CMAKE_ARGS=	-DNO_FATAL_WARNINGS:BOOL=ON
>+CMAKE_ARGS=	-DNO_FATAL_WARNINGS:BOOL=ON \
>+	-DISO_CODE_639_XML:STRING=${LOCALBASE}/share/xml/iso-codes/iso_639.xml \
>+	-DISO_CODE_3166:STRING=${LOCALBASE}/share/xml/iso-codes/iso_3166.xml
> 
>-GLIB_SCHEMAS=	org.yorba.geary.gschema.xml
>-
>-post-patch:
>-		@${REINPLACE_CMD} -e 's|abort $$option||g' \
>-			${WRKSRC}/configure
>+GLIB_SCHEMAS=	org.gnome.Geary.gschema.xml
> 
> .include <bsd.port.mk>
>diff --git c/mail/geary/distinfo i/mail/geary/distinfo
>index 0ccca3db9ffe..9c6869a7d38c 100644
>--- c/mail/geary/distinfo
>+++ i/mail/geary/distinfo
>@@ -1,2 +1,3 @@
>-SHA256 (gnome3/geary-0.10.0.tar.xz) = 46197a5a1b8b040adcee99082dbfd9fff9ca804e3bf0055a2e90b13214bdbca5
>-SIZE (gnome3/geary-0.10.0.tar.xz) = 917376
>+TIMESTAMP = 1507156458
>+SHA256 (gnome3/geary-0.12.0.tar.xz) = cef1093033ddfb52942b45c901562539cee7a192e981c7f19e2075ecb0c22446
>+SIZE (gnome3/geary-0.12.0.tar.xz) = 1064064
>diff --git c/mail/geary/files/patch-CMakeLists.txt i/mail/geary/files/patch-CMakeLists.txt
>new file mode 100644
>index 000000000000..8a3e7ca98921
>--- /dev/null
>+++ i/mail/geary/files/patch-CMakeLists.txt
>@@ -0,0 +1,10 @@
>+--- CMakeLists.txt.orig	2017-10-04 22:39:08 UTC
>++++ CMakeLists.txt
>+@@ -101,6 +101,7 @@ pkg_check_modules(ENCHANT QUIET enchant)
>+ pkg_check_modules(SQLITE3 sqlite3 REQUIRED)
>+ if (NOT ${SQLITE3_VERSION} VERSION_LESS 3.12)
>+   include(CheckSymbolExists)
>++  set(CMAKE_REQUIRED_INCLUDES /usr/local/include)
>+   check_symbol_exists(SQLITE_DBCONFIG_ENABLE_FTS3_TOKENIZER sqlite3.h HAVE_FTS3_TOKENIZER)
>+     if (NOT HAVE_FTS3_TOKENIZER)
>+         message(FATAL_ERROR "SQLite3 is missing FTS3 tokenizer support. Please compile it with -DSQLITE_ENABLE_FTS3."
>diff --git c/mail/geary/pkg-plist i/mail/geary/pkg-plist
>index 79c543c071d5..bc864da8fe64 100644
>--- c/mail/geary/pkg-plist
>+++ i/mail/geary/pkg-plist
>@@ -1,8 +1,9 @@
> bin/geary
> bin/geary-attach
>-share/appdata/geary.appdata.xml
>+lib/geary/web-extensions/libgeary-web-process.so
>+share/appdata/org.gnome.Geary.appdata.xml
> share/applications/geary-autostart.desktop
>-share/applications/geary.desktop
>+share/applications/org.gnome.Geary.desktop
> share/contractor/geary-attach.contract
> %%DATADIR%%/sql/version-001.sql
> %%DATADIR%%/sql/version-002.sql
>@@ -28,26 +29,7 @@ share/contractor/geary-attach.contract
> %%DATADIR%%/sql/version-022.sql
> %%DATADIR%%/sql/version-023.sql
> %%DATADIR%%/sql/version-024.sql
>-%%DATADIR%%/theming/message-viewer.css
>-%%DATADIR%%/theming/message-viewer.html
>-%%DATADIR%%/ui/accelerators.ui
>-%%DATADIR%%/ui/account_cannot_remove.glade
>-%%DATADIR%%/ui/account_list.glade
>-%%DATADIR%%/ui/account_spinner.glade
>-%%DATADIR%%/ui/app_menu.interface
>-%%DATADIR%%/ui/certificate_warning_dialog.glade
>-%%DATADIR%%/ui/composer.glade
>-%%DATADIR%%/ui/composer_accelerators.ui
>-%%DATADIR%%/ui/edit_alternate_emails.glade
>-%%DATADIR%%/ui/find_bar.glade
>-%%DATADIR%%/ui/login.glade
>-%%DATADIR%%/ui/message.glade
>-%%DATADIR%%/ui/password-dialog.glade
>-%%DATADIR%%/ui/preferences.glade
>-%%DATADIR%%/ui/remove_confirm.glade
>-%%DATADIR%%/ui/toolbar_empty_menu.ui
>-%%DATADIR%%/ui/toolbar_mark_menu.ui
>-%%DATADIR%%/ui/upgrade_dialog.glade
>+%%DATADIR%%/sql/version-025.sql
> share/gnome/help/geary/C/accounts.page
> share/gnome/help/geary/C/archive.page
> share/gnome/help/geary/C/bugs.page
>@@ -133,6 +115,42 @@ share/gnome/help/geary/it/search.page
> share/gnome/help/geary/it/shortcuts.page
> share/gnome/help/geary/it/star.page
> share/gnome/help/geary/it/write.page
>+share/gnome/help/geary/pl/accounts.page
>+share/gnome/help/geary/pl/archive.page
>+share/gnome/help/geary/pl/bugs.page
>+share/gnome/help/geary/pl/index.page
>+share/gnome/help/geary/pl/label.page
>+share/gnome/help/geary/pl/limits.page
>+share/gnome/help/geary/pl/overview.page
>+share/gnome/help/geary/pl/preferences.page
>+share/gnome/help/geary/pl/search.page
>+share/gnome/help/geary/pl/shortcuts.page
>+share/gnome/help/geary/pl/star.page
>+share/gnome/help/geary/pl/write.page
>+share/gnome/help/geary/pt_BR/accounts.page
>+share/gnome/help/geary/pt_BR/archive.page
>+share/gnome/help/geary/pt_BR/bugs.page
>+share/gnome/help/geary/pt_BR/index.page
>+share/gnome/help/geary/pt_BR/label.page
>+share/gnome/help/geary/pt_BR/limits.page
>+share/gnome/help/geary/pt_BR/overview.page
>+share/gnome/help/geary/pt_BR/preferences.page
>+share/gnome/help/geary/pt_BR/search.page
>+share/gnome/help/geary/pt_BR/shortcuts.page
>+share/gnome/help/geary/pt_BR/star.page
>+share/gnome/help/geary/pt_BR/write.page
>+share/gnome/help/geary/sv/accounts.page
>+share/gnome/help/geary/sv/archive.page
>+share/gnome/help/geary/sv/bugs.page
>+share/gnome/help/geary/sv/index.page
>+share/gnome/help/geary/sv/label.page
>+share/gnome/help/geary/sv/limits.page
>+share/gnome/help/geary/sv/overview.page
>+share/gnome/help/geary/sv/preferences.page
>+share/gnome/help/geary/sv/search.page
>+share/gnome/help/geary/sv/shortcuts.page
>+share/gnome/help/geary/sv/star.page
>+share/gnome/help/geary/sv/write.page
> share/icons/hicolor/16x16/apps/geary.png
> share/icons/hicolor/24x24/apps/geary.png
> share/icons/hicolor/256x256/apps/geary.png
>@@ -144,22 +162,23 @@ share/icons/hicolor/scalable/actions/detach-symbolic.svg
> share/icons/hicolor/scalable/actions/edit-symbolic.svg
> share/icons/hicolor/scalable/actions/format-text-remove-symbolic.svg
> share/icons/hicolor/scalable/actions/mail-archive-symbolic.svg
>-share/icons/hicolor/scalable/actions/mail-forward-rtl-symbolic.svg
>+share/icons/hicolor/scalable/actions/mail-drafts-symbolic-rtl.svg
>+share/icons/hicolor/scalable/actions/mail-drafts-symbolic.svg
>+share/icons/hicolor/scalable/actions/mail-forward-symbolic-rtl.svg
> share/icons/hicolor/scalable/actions/mail-forward-symbolic.svg
> share/icons/hicolor/scalable/actions/mail-inbox-symbolic.svg
> share/icons/hicolor/scalable/actions/mail-outbox-symbolic.svg
>-share/icons/hicolor/scalable/actions/mail-reply-all-rtl-symbolic.svg
>+share/icons/hicolor/scalable/actions/mail-reply-all-symbolic-rtl.svg
> share/icons/hicolor/scalable/actions/mail-reply-all-symbolic.svg
>-share/icons/hicolor/scalable/actions/mail-reply-sender-rtl-symbolic.svg
>+share/icons/hicolor/scalable/actions/mail-reply-sender-symbolic-rtl.svg
> share/icons/hicolor/scalable/actions/mail-reply-sender-symbolic.svg
>-share/icons/hicolor/scalable/actions/mail-sent-rtl-symbolic.svg
>+share/icons/hicolor/scalable/actions/mail-sent-symbolic-rtl.svg
> share/icons/hicolor/scalable/actions/mail-sent-symbolic.svg
>-share/icons/hicolor/scalable/actions/mail-spam-rtl-symbolic.svg
>-share/icons/hicolor/scalable/actions/mail-spam-symbolic.svg
> share/icons/hicolor/scalable/actions/marker-symbolic.svg
>-share/icons/hicolor/scalable/actions/tag-rtl-symbolic.svg
>+share/icons/hicolor/scalable/actions/tag-symbolic-rtl.svg
> share/icons/hicolor/scalable/actions/tag-symbolic.svg
> share/icons/hicolor/scalable/actions/text-x-generic-symbolic.svg
>+share/icons/hicolor/symbolic/apps/geary-symbolic.svg
> share/locale/ar/LC_MESSAGES/geary.mo
> share/locale/bs/LC_MESSAGES/geary.mo
> share/locale/ca/LC_MESSAGES/geary.mo
>@@ -190,6 +209,7 @@ share/locale/lt/LC_MESSAGES/geary.mo
> share/locale/ms/LC_MESSAGES/geary.mo
> share/locale/nb/LC_MESSAGES/geary.mo
> share/locale/nl/LC_MESSAGES/geary.mo
>+share/locale/oc/LC_MESSAGES/geary.mo
> share/locale/pl/LC_MESSAGES/geary.mo
> share/locale/pt/LC_MESSAGES/geary.mo
> share/locale/pt_BR/LC_MESSAGES/geary.mo
Comment 3 Carlos J. Puga Medina freebsd_committer 2017-10-28 15:21:03 UTC
Created attachment 187539 [details]
geary-0.12.0.diff
Comment 4 Carlos J. Puga Medina freebsd_committer 2017-10-28 15:28:14 UTC
Geary 0.12.0 works fine with vala-0.36 (tested on 10.3/amd64)

Some issues were fixed in the Makefile:

- LICENSE block
- Switch to USES=localbase
- s/-DISO_CODE_3166/-DISO_CODE_3166_XML
- Drop unneeded patch
- Cosmetic fixes
Comment 5 commit-hook freebsd_committer 2018-01-24 07:19:24 UTC
A commit references this bug:

Author: truckman
Date: Wed Jan 24 07:18:39 UTC 2018
New revision: 459818
URL: https://svnweb.freebsd.org/changeset/ports/459818

Log:
  Update mail/geary to 0.11.1

  Add license

  Use cmake:outsource

  Message about sqlite3

  PR:		210718, 221941
  Submitted by:	cpm

Changes:
  head/mail/geary/Makefile
  head/mail/geary/distinfo
  head/mail/geary/pkg-plist
Comment 6 Carlos J. Puga Medina freebsd_committer 2018-01-24 11:20:51 UTC
*** Bug 223790 has been marked as a duplicate of this bug. ***
Comment 7 Greg V 2018-01-24 15:57:04 UTC
Why was this FIXED with an update to 0.11.1, not 0.12.0?
Comment 8 Carlos J. Puga Medina freebsd_committer 2018-01-24 16:41:44 UTC
(In reply to Greg V from comment #7)

geary has been updated to 0.12.0 :)
Comment 9 Greg V 2018-01-24 17:20:06 UTC
(In reply to Carlos J. Puga Medina from comment #8)
Oh right :D only the commit message is wrong