Bug 211004 - [PATCH] lang/mono: update from 4.2.3.4 to 4.4.1.0
Summary: [PATCH] lang/mono: update from 4.2.3.4 to 4.4.1.0
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-mono mailing list
URL:
Keywords: patch
: 211371 (view as bug list)
Depends on: 211198 211371
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-11 12:40 UTC by Sergey Brunov
Modified: 2016-08-08 17:53 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (mono)


Attachments
The patch. (38.14 KB, patch)
2016-07-11 12:40 UTC, Sergey Brunov
no flags Details | Diff
Poudriere build log 10.3-RELEASE-p5 (6.29 KB, text/plain)
2016-07-26 19:31 UTC, Carsten Larsen
no flags Details
The patch (corrected). (37.08 KB, patch)
2016-07-26 21:48 UTC, Sergey Brunov
no flags Details | Diff
Reduced build log (7.62 KB, text/plain)
2016-08-07 18:00 UTC, Carsten Larsen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Brunov 2016-07-11 12:40:17 UTC
Created attachment 172375 [details]
The patch.

Hello!

The patch is attached.

Best regards,
Sergey Brunov.
Comment 1 Romain Tartière freebsd_committer 2016-07-11 12:47:50 UTC
Hi,

Unfortunately, devel/newtonsoft-json does not build with Mono 4.4.  This is currently blocking the update of lang/mono.

(a few other ports needed adjustments too, but workarounds have been found).
Comment 2 Sergey Brunov 2016-07-11 12:53:01 UTC
(In reply to Romain Tartière from comment #1)
Hello, Romain!

Could you please create the appropriate defect (bug) and specify the dependency on it as «blocking»?

Best regards,
Sergey Brunov.
Comment 3 Romain Tartière freebsd_committer 2016-07-25 18:11:40 UTC
*** Bug 211371 has been marked as a duplicate of this bug. ***
Comment 4 Carsten Larsen 2016-07-26 19:29:44 UTC
(In reply to sergey.v.brunov from comment #0)

Hmmm. When I try this patch in a clean Poudriere jail, I get this result:


===>  Patching for mono-4.4.1.0
===>  Applying FreeBSD patches for mono-4.4.1.0
  I can't seem to find a patch in there anywhere.
=> Patch patch-eglib-src-gunicode.c failed to apply cleanly.
*** Error code 1

Stop.
make: stopped in /usr/ports/lang/mono


I'll attach the build log.
Comment 5 Carsten Larsen 2016-07-26 19:31:08 UTC
Created attachment 173017 [details]
Poudriere build log 10.3-RELEASE-p5
Comment 6 Sergey Brunov 2016-07-26 21:48:51 UTC
Created attachment 173022 [details]
The patch (corrected).
Comment 7 Sergey Brunov 2016-07-26 21:49:46 UTC
(In reply to Carsten Larsen from comment #4)
Hello, Carsten!

Thank you very much for the feedback!
Sorry for inconvenience.

The patch has been corrected.

Best regards,
Sergey Brunov.
Comment 8 Carsten Larsen 2016-07-27 20:49:40 UTC
(In reply to sergey.v.brunov from comment #7)
Hi Sergey

With the new patch mono builds in clean jail:
10.3-STABLE FreeBSD 10.3-STABLE r303325 i386, port revision: 419151

Will do more testing with this specific configuration.
Comment 9 Carsten Larsen 2016-07-28 18:10:50 UTC
Sorry. Wrong report. Does still not build.
Comment 10 Sergey Brunov 2016-07-29 13:44:50 UTC
(In reply to Carsten Larsen from comment #9)
Hello, Carsten!

Could you please point out the errors?

Best regards,
Sergey Brunov.
Comment 11 Carsten Larsen 2016-07-29 16:42:08 UTC
(In reply to sergey.v.brunov from comment #10)
Hi Sergey

Same error as before. Remember to check the files in PATCHDIR are applied correctly. They are still there:
https://github.com/freebsd/freebsd-ports/tree/master/lang/mono/files
Comment 12 Sergey Brunov 2016-07-29 17:00:30 UTC
(In reply to Carsten Larsen from comment #11)
Hello, Carsten!

According to the documentation added and removed files — special case (https://www.freebsd.org/doc/en/books/porters-handbook/port-upgrading.html):
«Please mention any added or deleted files in the message, as they have to be explicitly specified to svn(1) when doing a commit.»

So, please apply the original patch (first version) and remove the «files/patch-eglib-src-gunicode.c» file manually (SVN and file system).

Best regards,
Sergey Brunov.
Comment 13 Sergey Brunov 2016-07-31 17:48:40 UTC
(In reply to Carsten Larsen from comment #11)
Hello, Carsten!

Did you succeed with the compilation?

Best regards,
Sergey Brunov.
Comment 14 Carsten Larsen 2016-07-31 21:38:45 UTC
(In reply to Sergey Brunov from comment #13)
Hi Sergey

Sorry. Didn't have time yet. I'll take a careful look as soon as I can.


Kind regards
Carsten Larsen
Comment 15 Carsten Larsen 2016-08-07 16:39:47 UTC
(In reply to Sergey Brunov from comment #13)
Hi Sergey. Building now. Should be ready within 24 hours.
Comment 16 Carsten Larsen 2016-08-07 18:00:45 UTC
Created attachment 173381 [details]
Reduced build log

(In reply to Sergey Brunov from comment #0)

Poudriere: No errors (10.3-STABLE r303325, i386)
Tested patch from attachment 172375 [details] with deleted files/patch-eglib-src-gunicode.c

Portlint: No errors.
WARN: Makefile: Consider adding support for a NLS knob to conditionally disable gettext support.
WARN: Makefile: Consider defining LICENSE.
WARN: /usr/local/poudriere/ports/subversive2/lang/mono/pkg-message: possible use of absolute pathname "/proc".
0 fatal errors and 3 warnings found.

(In reply to Sergey Brunov from comment #13)
Tested the patch on 10 stable and all seems fine.

Kind regards
Carsten Larsen
Comment 17 Romain Tartière freebsd_committer 2016-08-08 17:53:29 UTC
4.4.2.11 is now in the tree.