Bug 211107 - databases/oracle8-client: Fix run on 10.1+, Take MAINTAINER'ship
Summary: databases/oracle8-client: Fix run on 10.1+, Take MAINTAINER'ship
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Eugene Grosbein
URL:
Keywords: easy, needs-qa, patch, regression
Depends on:
Blocks:
 
Reported: 2016-07-14 09:38 UTC by Konstantin Stroykovskiy
Modified: 2017-07-16 11:03 UTC (History)
4 users (show)

See Also:
koobs: merge-quarterly?


Attachments
patch for freebsd/oci8stub.c (1.34 KB, text/x-csrc)
2016-07-14 09:38 UTC, Konstantin Stroykovskiy
no flags Details
this is single unified diff against original port directory (2.32 KB, patch)
2016-07-14 14:03 UTC, Konstantin Stroykovskiy
koobs: maintainer-approval+
Details | Diff
this is a single patch instead of the (1.58 KB, patch)
2016-07-14 14:22 UTC, Konstantin Stroykovskiy
no flags Details | Diff
new patch instead of 172512 with maintainer change (2.68 KB, patch)
2016-07-20 07:47 UTC, Konstantin Stroykovskiy
bonkor: maintainer-approval+
Details | Diff
patch instead of 172745. change the names of files to new style. (5.62 KB, patch)
2016-07-25 07:36 UTC, Konstantin Stroykovskiy
no flags Details | Diff
portlint log (421 bytes, text/plain)
2016-07-25 12:25 UTC, Konstantin Stroykovskiy
no flags Details
poudriere log (14.94 KB, text/plain)
2016-07-25 12:27 UTC, Konstantin Stroykovskiy
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Stroykovskiy 2016-07-14 09:38:20 UTC
Created attachment 172501 [details]
patch for freebsd/oci8stub.c

After MFC r270320 kern_sigaction rejects unknown flags in struct sigaction. Some functions in libclntst8.a use sigaction call with many unused bits in sa_flags, which are setted to up.

So, we change the call sigaction and mask unused bits.

There are two patches.
Patch for freebsd/redefine-syms.lst
##############################################################################
--- freebsd/redefine-syms.lst.orig      2005-06-20 20:23:35.000000000 +0400
+++ freebsd/redefine-syms.lst   2016-07-14 11:09:48.915819000 +0300
@@ -1,2 +1,4 @@
+connect __l_connect
 lseek  __l_lseek
 sigprocmask __l_sigprocmask
+sigaction __l_sigaction
##############################################################################
and patch for freebsd/oci8stub.c (attached).
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2016-07-14 12:16:54 UTC
CC original committer of (base) r270320

@Konstantin (reporter), can you please attach both changes as a single unified diff against the port please. You may use the method outlined here to automatically create patches as category/port/files/patch-* files:

https://www.freebsd.org/doc/en/books/porters-handbook/slow-patch.html
Comment 2 Konstantin Stroykovskiy 2016-07-14 14:03:34 UTC
Created attachment 172512 [details]
this is single unified diff against original port directory
Comment 3 Konstantin Stroykovskiy 2016-07-14 14:22:03 UTC
Created attachment 172513 [details]
this is a single patch instead of the
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2016-07-14 14:37:58 UTC
Comment on attachment 172512 [details]
this is single unified diff against original port directory

Port is unmaintained, implicit approval
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2016-07-14 14:38:18 UTC
Thank you Konstantin
Comment 6 Konstantin Stroykovskiy 2016-07-20 07:47:11 UTC
Created attachment 172745 [details]
new patch instead of 172512 with maintainer change
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2016-07-20 08:42:21 UTC
@Konstantin, thank you for the updated patch.

Can you confirm this passes QA (portlint, poudriere) please:

https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/testing.html
Comment 8 Konstantin Stroykovskiy 2016-07-25 07:36:22 UTC
Created attachment 172965 [details]
patch instead of 172745. change the names of files to new style.
Comment 9 Konstantin Stroykovskiy 2016-07-25 12:25:57 UTC
Created attachment 172968 [details]
portlint log

First warning is false alarm.
Comment 10 Konstantin Stroykovskiy 2016-07-25 12:27:22 UTC
Created attachment 172969 [details]
poudriere log
Comment 11 Bartek Rutkowski freebsd_committer 2016-12-09 16:35:52 UTC
Hi,

This patch fails to build on 11.0-RELEASE with the following plist errors:

===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: oracle8-client/freebsd/.depend.C-ctype.o
Error: Orphaned: oracle8-client/freebsd/.depend.ecvt.o
Error: Orphaned: oracle8-client/freebsd/.depend.oci8stub.o
Error: Orphaned: oracle8-client/freebsd/.depend.strtod.o
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1
Comment 12 Konstantin Stroykovskiy 2016-12-12 09:57:04 UTC
(In reply to Bartek Rutkowski from comment #11)
Hi! This patch is against the whole original port directory. So, to apply this patch you must do something like this:

cd /usr/ports
fetch [the-path-to-patch-with-name-mypatch]
cp -R databases/oracle8-client databases/oracle8-client.orig
patch --remove-empty-files -V none < mypatch
cd databases/oracle8-client
make install
Comment 13 Rene Ladan freebsd_committer 2017-03-07 19:20:10 UTC
This software seems to be expired long ago, the WWW link does not work anymore and Oracle only supports versions 11 and 12. Closing this PR now, the port expired.
Comment 14 Konstantin Stroykovskiy 2017-03-08 09:19:24 UTC
(In reply to Rene Ladan from comment #13)
> the WWW link does not work anymore

It can be changed to functioning.

> and Oracle only supports versions 11 and 12. 

This client works fine with any versions of Oracle server (including 11 and 12).

> Closing this PR now, the port expired.

But there are people using this port.
Unfortunately, there is no other good way to connect Oracle database from FreeBSD besides this port. linux-oracle-instantclient is working under linux infrastructure and it is impossible to use it with native perl. So, databases/p5-DBD-Oracle will be unusable too.
Comment 15 commit-hook freebsd_committer 2017-05-18 15:57:30 UTC
A commit references this bug:

Author: eugen
Date: Thu May 18 15:56:23 UTC 2017
New revision: 441157
URL: https://svnweb.freebsd.org/changeset/ports/441157

Log:
  Re-add databases/oracle8-client removed with r435735 as there is user demand for it.
  The only way for native FreeBSD binaries to connect to modern Oracle databases is
  usage of OCI8 libraries supplied by the port. Additional changes:

  - integrate patch supplied with PR 211107;
  - assign maintainership to the submitter;
  - supply additional MASTER_SITE;
  - dead WWW link replaced with working copy of old one;
  - bump PORTREVISION.

  PR:		211107
  Approved by:	vsevolod (mentor)

Changes:
  head/MOVED
  head/databases/Makefile
  head/databases/oracle8-client/
  head/databases/oracle8-client/Makefile
  head/databases/oracle8-client/files/patch-freebsd-oci8stub.c
  head/databases/oracle8-client/files/patch-freebsd-redefine-syms.lst
  head/databases/oracle8-client/pkg-descr
Comment 16 Kubilay Kocak freebsd_committer freebsd_triage 2017-07-16 11:03:21 UTC
Update resolution and assign to committer that resolved.

@Eugen / @Rene if you could do this for issues you resolve in future (whether by commit/FIXED or otherwise) that would be greatly appreciated (and a time saver). Thanks!