Bug 211167 - games/retroarch: Update to 1.3.6
Summary: games/retroarch: Update to 1.3.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitry Marakasov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-17 08:43 UTC by Yuri Victorovich
Modified: 2016-08-23 11:14 UTC (History)
2 users (show)

See Also:


Attachments
patch (6.09 KB, patch)
2016-07-17 08:43 UTC, Yuri Victorovich
yuri: maintainer-approval+
Details | Diff
patch (6.40 KB, patch)
2016-07-18 20:39 UTC, Yuri Victorovich
no flags Details | Diff
Proposed patch (since 418497 revision) (5.49 KB, patch)
2016-07-22 07:12 UTC, lightside
no flags Details | Diff
Proposed patch (since 418497 revision) (5.49 KB, patch)
2016-07-22 10:14 UTC, lightside
no flags Details | Diff
Proposed patch (since 418497 revision) (5.41 KB, patch)
2016-07-22 12:07 UTC, lightside
yuri: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2016-07-17 08:43:23 UTC
Created attachment 172601 [details]
patch

Passes poudriere on 10.3 amd64
Comment 1 Dmitry Marakasov freebsd_committer 2016-07-18 20:15:45 UTC
What's MAN1PAGES used for? Also, please do not submit no-op patch changes.
Comment 2 Yuri Victorovich freebsd_committer 2016-07-18 20:39:20 UTC
Created attachment 172677 [details]
patch

Thanks for noticing a bug with a no-op patch.
Comment 3 lightside 2016-07-22 07:12:34 UTC
Created attachment 172826 [details]
Proposed patch (since 418497 revision)

Hello Yuri Victorovich and Dmitry Marakasov.

I would like to propose slightly different patch, with following changes (including maintainer's changes):
- Specify MAN_DIR define with path to man pages for MAKE_ARGS
- Remove MAN1PAGES define [1]
- Patch qb/config.libs.sh file in one place with using sed patches; remove files/patch-qb_config.libs.sh file
- Add sed patch for Makefile to fix installation of man pages
- Remove manual compression of man pages
- Remove removal of share/man directory
- Correct files/patch-libretro-common_rthreads_rthreads.c and files/patch-qb_qb.params.sh [1]
- Adapt pkg-plist [1]

[1] - changes made by maintainer

Also, I manually regenerated TIMESTAMP value for distinfo file with using following command:
% make clean extract && find work/* -type f -print0 | xargs -0 stat -f '%m' | sort -u | tail -1
based on "last modification time of the source" files, according to "SOURCE_DATE_EPOCH specification": https://reproducible-builds.org/specs/source-date-epoch/

Possible to specify changelog, if needed:
https://github.com/libretro/RetroArch/compare/v1.3.4...v1.3.6
Comment 4 lightside 2016-07-22 10:14:16 UTC
Created attachment 172830 [details]
Proposed patch (since 418497 revision)

Moved MAN_DIR define to CONFIGURE_ENV.

- Add MAN_DIR define with path to man pages to CONFIGURE_ENV
Comment 5 lightside 2016-07-22 12:07:48 UTC
Created attachment 172833 [details]
Proposed patch (since 418497 revision)

Actually, no need to patch Makefile. The installed man pages compressed automatically.
Also, possible to use ${MANPREFIX}/man, instead of ${PREFIX}/man.
Comment 6 Dmitry Marakasov freebsd_committer 2016-07-26 17:31:02 UTC
Back to pool, ENOTIME because of vacation.
Comment 7 Dmitry Marakasov freebsd_committer 2016-08-18 13:09:28 UTC
Take again
Comment 8 Dmitry Marakasov freebsd_committer 2016-08-23 11:14:41 UTC
Minor change: removed check around STRIP_CMD. You don't need that since STRIP_CMD will be /usr/bin/true hence no-op if stripping is disabled.
Comment 9 commit-hook freebsd_committer 2016-08-23 11:14:58 UTC
A commit references this bug:

Author: amdmi3
Date: Tue Aug 23 11:14:38 UTC 2016
New revision: 420662
URL: https://svnweb.freebsd.org/changeset/ports/420662

Log:
  - Update to 1.3.6

  PR:		211167
  Submitted by:	yuri@rawbw.com, lightside@gmx.com
  Approved by:	yuri@rawbw.com (maintainer)

Changes:
  head/games/retroarch/Makefile
  head/games/retroarch/distinfo
  head/games/retroarch/files/patch-libretro-common_rthreads_rthreads.c
  head/games/retroarch/files/patch-qb_config.libs.sh
  head/games/retroarch/files/patch-qb_qb.params.sh
  head/games/retroarch/pkg-plist