Bug 211228 - devel/git: Add PCRE option
Summary: devel/git: Add PCRE option
Status: Closed DUPLICATE of bug 211231
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Renato Botelho
URL:
Keywords: easy, feature, needs-qa, patch
Depends on:
Blocks:
 
Reported: 2016-07-19 13:40 UTC by Akinori MUSHA
Modified: 2016-08-03 13:01 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (garga)
koobs: merge-quarterly?


Attachments
The patch (1.21 KB, patch)
2016-07-19 13:40 UTC, Akinori MUSHA
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Akinori MUSHA freebsd_committer 2016-07-19 13:40:48 UTC
Created attachment 172722 [details]
The patch

Many package vendors nowadays [*] ship git with the PCRE support enabled, and I believe our port should at least offer an option to enable it.

My patch has PCRE in the default options list, but the maintainer may think a different way and I'll be fine with it as long as there is an option.

FWIW, the only use for libpcre in git is currently git grep's -P option, which can be enabled by default by setting "grep.patternType" to "perl".  PCRE works great for code search.

[*] Debian/Ubuntu, Fedora, Homebrew, MacPorts, to name a few
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2016-07-19 13:44:44 UTC
Great issue report
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2016-07-20 08:20:50 UTC
Superseded by bug 211231 (marked In Progress)

*** This bug has been marked as a duplicate of bug 211231 ***
Comment 3 commit-hook freebsd_committer 2016-08-03 13:01:44 UTC
A commit references this bug:

Author: mat
Date: Wed Aug  3 13:01:06 UTC 2016
New revision: 419517
URL: https://svnweb.freebsd.org/changeset/ports/419517

Log:
  Add a PCRE option to allow git grep to be build with pcre support.

  tl:dr; git grep -P now works.

  Most package managers enable it by default, so enable it by default too.

  PR:		211228
  Submitted by:	mat, knu
  Approved by:	maintainer (or timeout, see PR)
  Sponsored by:	Absolight

Changes:
  head/devel/git/Makefile