Bug 211229 - net-mgmt/collectd5: Reading kstat value "stolen" failed
Summary: net-mgmt/collectd5: Reading kstat value "stolen" failed
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-19 13:50 UTC by Ruben Kerkhof
Modified: 2016-08-05 21:14 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (ports)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ruben Kerkhof 2016-07-19 13:50:48 UTC
Collectd is logging this every few seconds:
Jul 19 15:23:02 stor2b collectd[801]: zfs_arc plugin: Reading kstat value "stolen" failed.

But this statistic doesn't exist:

root@stor2b:~ # sysctl -a | grep zfs | grep stolen
root@stor2b:~ # 


root@stor2b:~ # freebsd-version -uk
10.3-RELEASE-p4
10.3-RELEASE-p5

root@stor2b:~ # pkg version | grep collectd5
collectd5-5.5.1_4                  =

Installed from pkg, not ports.
Comment 1 Krzysztof 2016-07-21 20:16:19 UTC
Hmm, it is strange for me. AFAIR one of the latest patches was applied to disable "stolen" values. I don't remember which one.

OK. I've checked it out: patch from beginning of February removed collecting stolen values.

So I think that's a question to FreeBSD developers if it is a mistake that's collectd ties to monitor this value
Comment 2 Ruben Kerkhof 2016-07-22 11:19:55 UTC
(In reply to Krzysztof from comment #1)

I see you've added the patch for 5.5.1 in https://bugs.freebsd.org/206660.

I'm sorry, but I don't understand your last question.
Your own words were "add patch for zfs_arc.c to disable kstat.zfs.misc.arcstats.stolen"
Why do you think this is a mistake?

I think the idea is right, but for some reason it doesn't work with a binary collectd pkg installed on 10.3.
Comment 3 Ruben Kerkhof 2016-07-22 11:50:07 UTC
I just checked a 12-CURRENT system, and there the issue is gone, so at least the patch works.

Could it be that the pkg builders are not on 10.3 yet?
Comment 4 Ruben Kerkhof 2016-07-22 12:40:22 UTC
I just build a binary package on a 10.3 system with 'make package' and installed it, and the issue is gone. So this only seems to affect the binary collectd5 package from the FreeBSD pkg repo.
Comment 5 Krzysztof 2016-07-22 18:27:11 UTC
Yes, you are right. Writing "it is a mistake" I was meaning that binary pkg repository (official) has a problem. Telling the truth I'm using my own repository that's why I was suprised :-)))

So I think we can close this ticket

Greetings,
Comment 6 Ruben Kerkhof 2016-07-22 18:53:19 UTC
(In reply to Krzysztof from comment #5)

Well, closing this ticket doesn't really fix the issue. Is there nothing that can be done?
Comment 7 Brad Davis freebsd_committer 2016-08-05 20:48:44 UTC
The pkg builders run the oldest version of the branch.  So in this case 10.1.
Comment 8 Ruben Kerkhof 2016-08-05 21:14:49 UTC
Thanks for letting me know Brad, and for providing a patch for upstream to remove 'stolen' altogether. It will be in Collectd 5.6 due next month. By then this issue will resolve itself.