Bug 211270 - net/mediastreamer: missing dependency on multimedia/v4l_compat
Summary: net/mediastreamer: missing dependency on multimedia/v4l_compat
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Tijl Coosemans
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-21 12:19 UTC by Mark.Martinec
Modified: 2016-07-21 13:02 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark.Martinec 2016-07-21 12:19:52 UTC
Building mediastreamer-2.12.1 under poudriere on FreeBSD 10.4
fails due to a missing dependency:


  =======================<phase: build-depends  >============================
  ===>   mediastreamer-2.12.1 depends on package: v4l_compat>=1.0.20120501 - not found
  ===>   mediastreamer-2.12.1 depends on package: /.npkg/All/v4l_compat-1.6.3.txz - not found
  ===>   USE_PACKAGE_DEPENDS_ONLY set - not building missing dependency from source
  *** Error code 1
  Stop.
  make: stopped in /usr/ports/net/mediastreamer


The full log is available at:
  https://www.ijs.si/usr/mark/tmp/mediastreamer-2.12.1.log
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2016-07-21 12:26:02 UTC
The error appears to indicate that because USE_PACKAGE_DEPENDS_ONLY is set, that poudriere wont build the (declared) dependency, in order to satisfy it, not that the dependency is not declared (thus missing).

The question as to why there's no v4l_compat package available is a separate question.

Also, please include build logs when necessary as attachments rather than external links so that all the information about an issue can be contained within the issue tracker
Comment 2 Tijl Coosemans freebsd_committer 2016-07-21 12:35:55 UTC
I cannot help with this because I've never used poudriere.  You need to make sure somehow that poudriere builds v4l_compat.  There's nothing wrong with mediastreamer as far as I can see.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2016-07-21 13:02:06 UTC
@Tijl, I'm re-assigning this issue to you given it was reported against a port you maintain, but closing Not A Bug as per my and your comments