Bug 211354 - freebsd-update cannot update 11.0-BETA2
Summary: freebsd-update cannot update 11.0-BETA2
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 10.3-RELEASE
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-25 01:33 UTC by Masachika ISHIZUKA
Modified: 2016-08-07 09:01 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Masachika ISHIZUKA 2016-07-25 01:33:08 UTC
freebsd-update prior r302539 cannot update 11.0-* due to sanity check.

You must update freebsd-update to r302539 as follows.

% freebsd-version -ku
10.3-RELEASE-p4
10.3-RELEASE-p5
% su
# cd /usr/sbin
# cp -p freebsd-update freebsd-update.org
# patch < freebsd-update.sh.diff

-------------
% cat freebsd-update.sh.diff
--- stable/11/usr.sbin/freebsd-update/freebsd-update.sh 2016/07/08 00:04:57     302408
+++ stable/11/usr.sbin/freebsd-update/freebsd-update.sh 2016/07/11 04:50:32     302539
@@ -1250,7 +1250,7 @@
 
        # Check that the first four fields make sense.
        if gunzip -c < files/$1.gz |
-           grep -qvE "^[a-z]+\|[0-9a-z]+\|${P}+\|[fdL-]\|"; then
+           grep -qvE "^[a-z]+\|[0-9a-z-]+\|${P}+\|[fdL-]\|"; then
                fetch_metadata_bogus ""
                return 1
        fi
Comment 1 Masachika ISHIZUKA 2016-07-26 07:26:34 UTC
FreeBSD-EN-16:09.freebsd-update correct this problem.
Comment 2 Xin LI freebsd_committer 2016-08-07 07:03:20 UTC
*** Bug 211398 has been marked as a duplicate of this bug. ***
Comment 3 Mark Millard 2016-08-07 09:01:54 UTC
Doug Hardie doug at mail.sermon-archive.info wrote on Sun Aug 7 07:04:26 UTC 2016 :

> On 6 August 2016, at 23:37, Kurt Jaeger <lists at opsec.eu> wrote:
> 
> Hi!
> 
>> Is there any information available on when freebsd-update might
>> be corrected to upgrade some 9.3 systems to 11.0?
> 
> Does
> 
> https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=211354
> 
> help ?
. . .

 No that didn't fix it.  That change was in the EN which was applied and while the line numbers are different in 9.3, the extra character is in my copy.