Bug 211464 - pkg 1.8.2 upgrade chown mysql -> 88
Summary: pkg 1.8.2 upgrade chown mysql -> 88
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-pkg mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-30 17:43 UTC by Aleks
Modified: 2018-02-07 11:12 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleks 2016-07-30 17:43:18 UTC
pkg 1.8.2 upgrade chown mysql -> 88 

FIXED :
chown -R mysql:mysql /var/db/mysql
Comment 1 John Marino freebsd_committer 2016-08-03 13:51:32 UTC
This PR is cryptic (an example of not explaining the problem nor why the proposed the best fix).  In any case, assign to pkg.
Comment 2 dasti 2016-09-13 09:01:50 UTC
I think I can help on this one :)


on freeBSD 10.3

installed package mysql56-server
- 'pkg install mysql56-server'

changed pkg configuration file to the 'lastest'
- from 	this line -- 'url: "pkg+http://pkg.FreeBSD.org/${ABI}/quarterly",'
- to this line -- 'url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest",'

refreshed and it updated mysql server from  5.6.30 to 5.6.32
- 'pkg update'

tried to start mysql doesn't work, no error in /var/log/message
error appears in mysql's error log file (sorry I don't have the path anymore)


the fix that worked for me is to give back permissions for the user mysql to the this directory -> /var/db/mysql

a link to someone getting the same problem (certainly on another OS) -> http://dba.stackexchange.com/a/99365
Comment 3 Walter Schwarzenfeld freebsd_triage 2018-02-03 09:04:23 UTC
Is this still relevant?
Comment 4 dasti 2018-02-07 11:12:11 UTC
didn't had the time to test on freebsd 11.1
my guess is that it's a port problem (?)