Bug 211488 - powerpc iso broken / does not burn correctly
Summary: powerpc iso broken / does not burn correctly
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 11.0-BETA3
Hardware: powerpc Any
: --- Affects Some People
Assignee: freebsd-ppc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-31 22:30 UTC by Sevan Janiyan
Modified: 2017-04-07 12:20 UTC (History)
5 users (show)

See Also:


Attachments
11-RELEASE iso burnt with disk utility on OS X Tiger (182.84 KB, image/png)
2016-09-27 19:55 UTC, Sevan Janiyan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sevan Janiyan 2016-07-31 22:30:07 UTC
The published powerpc iso files do not appear to burn correctly on disk utility on OS X.
Confirmed on 10.3-RELEASE & 11-BETA3 powerpc iso using CD & DVD media with disk utility application on OS X.
With DVD media for example, 523.7MB is used up yet 0 directories & files on disk.
Comment 1 sysprint0 2016-08-05 05:02:32 UTC
I confirm the problem with the 10.3 PPC image
Burning the ISO on a Mac creates a bootable but empty disk with a subsequent kernel not found msg when booting.

Looking in the mail archives I found

https://lists.freebsd.org/pipermail/freebsd-ppc/2015-May/007608.html

Is the exact symptom but was answered with a failing capacitor !!

On my PPC Mac I managed to get the boot_only_iso to finally work after rebuilding the iso to a dmg

I have now run out DVD's to test this further.

There is some kind of extra layer in the PPC distribution iso that shouldn't be there.

Best regards
Comment 2 Baptiste Daroussin freebsd_committer 2016-09-27 11:24:36 UTC
Adding re@, seems like the generated iso are still not burnable (according to the reported, including 11.0-RELEASE isos) from OSX, probably an incompatibility between the OSX burner and the format we are using, don't know. I have no OSX so I have no clue how to test
Comment 3 Sevan Janiyan 2016-09-27 19:55:38 UTC
Created attachment 175202 [details]
11-RELEASE iso burnt with disk utility on OS X Tiger
Comment 4 Sevan Janiyan 2016-09-27 20:00:02 UTC
Note the details on space usage at the bottom of the screenshot.
Comment 5 sysprint0 2016-10-01 04:46:04 UTC
Baptiste

Could you provide details of your ISO creation method please ?
Program you use and flags you parse to it etc.

Your current method creates a perfectly bootable disk while the kernel layer and everything else required somehow is not found.

Do you create the ISO with the actual files present locally ?
Or do you use a truck load of symlinks during the creation ?

If you use symlinks then maybe 1 two many of them is interfering at the ISO's primary disk root directory.

Hope this helps in some way.

Kind regards from the South Pacific.
Comment 6 Mark Millard 2016-10-01 05:37:03 UTC
(In reply to sysprint0 from comment #5)

Examples scripts likely used to make the iso's, using stable/11 and releng/11.0 as examples:

https://svnweb.freebsd.org/base/stable/11/release/powerpc/mkisoimages.sh

https://svnweb.freebsd.org/base/releng/11.0/release/powerpc/mkisoimages.sh


In other words looking around in .../release/... for the context of interest likely has some of the material for how the release is made.
Comment 7 Sevan Janiyan freebsd_committer 2016-10-01 10:22:21 UTC
(In reply to sysprint0 from comment #5)
I'm using the stock images (xz compressed) from mirrors.

I fetch the archive, unxz, launch disk utility in OS X, press the burn button & point to the uncompressed .iso file.

system starts burning & commences with closing the session.

I'm using RW disks but have tried a full & quick erase in between.
Tried using CDRW & DVD+RW media.

Do not have problems burning other BSD iso images on said media using same burner.
Comment 8 Sevan Janiyan freebsd_committer 2016-10-01 10:28:01 UTC
(In reply to Sevan Janiyan from comment #7)
"system starts burning & commences with closing the session."

system starts burning & commences to immediately closing the session.

Process is finished under a minute. Burner is not that fast. :)
Comment 9 Sevan Janiyan 2017-01-08 04:08:37 UTC
Issue is definitely with Disk Utility.app on OS X
Just managed to burn the FreeBSD-12.0-CURRENT-powerpc-20161221-r310361-disc1.iso using cdrecord without issue.

cdrecord speed=8 dev=/dev/cd0c FreeBSD-12.0-CURRENT-powerpc-20161221-r310361-disc1.iso
cdrecord: No write mode specified.
cdrecord: Assuming -sao mode.
cdrecord: If your drive does not accept -sao, try -tao.
cdrecord: Future versions of cdrecord may have different drive dependent defaults.
Cdrecord-ProDVD-ProBD-Clone 3.01 (powerpc-apple-netbsd7.99.56) Copyright (C) 1995-2015 Joerg Schilling
scsidev: '/dev/cd0c'
devname: '/dev/cd0c'
scsibus: -2 target: -2 lun: -2
Using libscg version 'schily-0.9'.
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : 'MATSHITA'
Identifikation : 'CD-RW  CW-8123  '
Revision       : 'CAD4'
Device seems to be: Generic mmc2 DVD-ROM.
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-2 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
cdrecord: Warning: Cannot read drive buffer.
cdrecord: Warning: The DMA speed test has been skipped.
Starting to write CD/DVD/BD at speed 8 in real SAO mode for single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Turning BURN-Free off
cdrecord: WARNING: Drive returns wrong startsec (0) using -150
Track 01: Total bytes read/written: 520865792/520865792 (254329 sectors). 



Copyright (c) 1992-2016 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 12.0-CURRENT #0 r310361: Wed Dec 21 15:49:56 UTC 2016

root@releng3.nyi.freebsd.org:/usr/obj/powerpc.powerpc/usr/src/sys/GENERIC powerpc
gcc version 4.2.1 20070831 patched [FreeBSD]
WARNING: WITNESS option enabled, expect reduced performance.
VT(ofwfb): resolution 1440x900
cpu0: IBM PowerPC 970FX revision 3.0, 900.40 MHz
cpu0: Features dc000000<PPC32,PPC64,ALTIVEC,FPU,MMU>
cpu0: HID0 511081<NAP,DPM,NHR,TBEN,ENATTN>
real memory  = 2126036992 (2027 MB)
avail memory = 2019106816 (1925 MB)
random: unblocking device.
random: entropy device external interface
kbd0 at kbdmux0
ofwbus0: <Open Firmware Device Tree> on nexus0
cpulist0: <Open Firmware CPU Group> on ofwbus0
cpu0: <Open Firmware CPU> on cpulist0
pcr0: <PPC 970 Power Control Register> on cpu0
powermac_nvram0: <Apple NVRAM> mem 0xfff04000-0xfff07fff on ofwbus0
powermac_nvram0: bank0 generation 222, bank1 generation 221
unin0: <Apple UniNorth System Controller> mem 0xf8000000-0xf8ffffff on ofwbus0
unin0: Version 57
iichb0: <Keywest I2C controller> mem 0xf8001000-0xf8001fff irq 0 on unin0
iicbus0: <OFW I2C bus> on iichb0
iicbus0: <unknown card> at addr 0x1c0
htpic0: <OpenPIC Interrupt Controller> mem 0xf8040000-0xf807ffff irq 224 on unin0
pcib0: <Apple U3 Host-AGP bridge> mem 0xf0000000-0xf1ffffff on ofwbus0
pci0: <OFW PCI bus> on pcib0
vgapci0: <VGA-compatible display> mem 0x91000000-0x91ffffff,0xa0000000-0xa7ffffff irq 187 at device 16.0 on pci0
backlight0: <PowerBook backlight for nVidia graphics> on vgapci0
vgapci0: Boot video device
agp0: <Apple U3 AGP Bridge> on hostb0
pcib1: <IBM CPC9X5 HyperTransport Tunnel> mem 0xf2000000-0xf47fffff,0xf8070000-0xf8070fff on ofwbus0
pcib1: 86 HT IRQs on device 1.0
pci1: <OFW PCI bus> on pcib1
pcib2: <OFW PCI-PCI bridge> at device 1.0 on pci1
pci2: <OFW PCI bus> on pcib2
gem0: <Apple Shasta GMAC Ethernet> mem 0x80400000-0x805fffff irq 168 at device 15.0 on pci2
miibus0: <MII bus> on gem0
bmtphy0: <BCM5221 10/100 media interface> PHY 0 on miibus0
bmtphy0:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto, auto-flow
gem0: 10kB RX FIFO, 4kB TX FIFO
gem0: Ethernet address: 00:0d:93:
pcib3: <OFW PCI-PCI bridge> at device 2.0 on pci1
pci3: <OFW PCI bus> on pcib3
macio0: <Shasta I/O Controller> mem 0x80000000-0x8007ffff at device 7.0 on pci3
openpic0: <OpenPIC Interrupt Controller> mem 0x40000-0x7ffff on macio0
macgpio0: <MacIO GPIO Controller> mem 0x50-0x8a on macio0
scc0: <Zilog Z8530 dual channel SCC> mem 0x13000-0x13fff,0x8400-0x84ff,0x8500-0x85ff,0x8600-0x86ff,0x8700-0x87ff irq 151,145,146,152,147,148 on macio0
uart0: <z8530, channel A> on scc0
uart1: <z8530, channel B> on scc0
iichb1: <Keywest I2C controller> mem 0x18000-0x18fff irq 155 on macio0
iicbus1: <OFW I2C bus> on iichb1
iicbus1: <unknown card> at addr 0x1c0
snapper0: <Texas Instruments TAS3004 Audio Codec> at addr 0x6a on iicbus1
pcm0: <Apple I2S Audio Controller> mem 0x10000-0x10fff,0x8000-0x80ff,0x8100-0x81ff irq 156,139,140,157,141,142 on macio0
pci3: <network> at device 1.0 (no driver attached)
ohci0: <NEC uPD 9210 USB controller> mem 0x80082000-0x80082fff irq 198 at device 11.0 on pci3
usbus0 on ohci0
ohci1: <NEC uPD 9210 USB controller> mem 0x80081000-0x80081fff irq 198 at device 11.1 on pci3
usbus1 on ohci1
ehci0: <NEC uPD 72010x USB 2.0 controller> mem 0x80080000-0x800800ff irq 198 at device 11.2 on pci3
usbus2: EHCI version 1.0
usbus2 on ehci0
pcib4: <OFW PCI-PCI bridge> at device 3.0 on pci1
pci4: <OFW PCI bus> on pcib4
atapci0: <ServerWorks K2 SATA150 controller> mem 0x80102000-0x80103fff irq 138 at device 12.0 on pci4
pcib1: failed to reserve resource for pcib4
atapci0: 0x10 bytes of rid 0x20 res 4 failed (0, 0xffffffffffffffff).
ata2: <ATA channel> at channel 0 on atapci0
ata3: <ATA channel> at channel 1 on atapci0
ata4: <ATA channel> at channel 2 on atapci0
ata5: <ATA channel> at channel 3 on atapci0
ata0: <Shasta Kauai ATA Controller> mem 0x80104000-0x80107fff irq 166,165 at device 13.0 on pci4
fwohci0: <1394 Open Host Controller Interface> mem 0x80100000-0x80100fff irq 167 at device 14.0 on pci4
fwohci0: OHCI version 1.0 (ROM=0)
fwohci0: No. of Isochronous channels is 8.
fwohci0: EUI64 00:0d:93:ff:fe:
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:0d:93:
fwe0: Ethernet address: 02:0d:93:
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwohci0: Initiate bus reset
fwohci0: fwohci_intr_core: BUS reset
fwohci0: PhysicalUpperBound register is not implemented.  Physical memory access is limited to the first 4GB
fwohci0: PhysicalUpperBound = 0x00000000
fwohci0: fwohci_intr_core: node_id=0x00000000, SelfID Count=2, CYCLEMASTER mode
smu0: <Apple System Management Unit> on ofwbus0
iichb2: <SMU I2C controller> on smu0
iicbus2: <OFW I2C bus> on iichb2
ds17750: <Temp-Monitor DS1775> at addr 0x92 on iicbus2
iicbus2: <unknown card> at addr 0xd4
iichb3: <SMU I2C controller> on smu0
iicbus3: <OFW I2C bus> on iichb3
cryptosoft0: <software crypto> on nexus0
NULL mp in getnewvnode()
Timecounter "timebase" frequency 33333333 Hz quality 0
Event timer "decrementer" frequency 33333333 Hz quality 1000
Timecounters tick every 1.000 msec
firewire0: 1 nodes, maxhop <= 0 cable IRM irm(0)  (me)
firewire0: bus manager 0
usbus0: 12Mbps Full Speed USB v1.0
usbus1: 12Mbps Full Speed USB v1.0
ugen1.1: <NEC OHCI root HUB> at usbus1
uhub0: <NEC OHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus1
ugen0.1: <NEC OHCI root HUB> at usbus0
uhub1: <NEC OHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
usbus2: 480Mbps High Speed USB v2.0
ugen2.1: <NEC EHCI root HUB> at usbus2
uhub2: <NEC EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus2
uhub0: 2 ports with 2 removable, self powered
uhub1: 3 ports with 3 removable, self powered
uhub2: 5 ports with 5 removable, self powered
ugen2.2: <Apple, Inc. Keyboard Hub> at usbus2
uhub3 on uhub2
uhub3: <Apple, Inc. Keyboard Hub, class 9/0, rev 2.00/95.15, addr 2> on usbus2
cd0 at ata0 bus 0 scbus4 target 0 lun 0
cd0: <MATSHITA DVD-R   UJ-825 DBN7> Removable CD-ROM SCSI device
cd0: 66.700MB/s transfers (UDMA4, ATAPI 12bytes, PIO 65534bytes)
cd0: Attempt to query device size failed: NOT READY, Medium not present
ada0 at ata2 bus 0 scbus0 target 0 lun 0
ada0: <Hitachi HDT725032VLA360 V54OA73A> ATA-7 SATA 2.x device
ada0: Serial Number VFD200XXXXXXXX
ada0: 150.000MB/s transfers (SATA 1.x, UDMA5, PIO 8192bytes)
ada0: 305244MB (625140335 512 byte sectors)uhub3: 3 ports with 2 removable, bus powered

taskqgroup_adjust failed cnt: 1 stride: 1 mp_ncpus: 1 smp_started: 0
taskqgroup_adjust failed cnt: 1 stride: 1 mp_ncpus: 1 smp_started: 0
WARNING: WITNESS option enabled, expect reduced performance.
Trying to mount root from ufs:/dev/ada0s4 [rw]...
Comment 10 sysprint0 2017-02-01 07:32:45 UTC
Hi Sevan.
Good news you have found a work around.
My ppc laptop got trashed during a recent big earthquake and have only just got things going again.

To our FreeBSD friends.

The release ISO's you present look perfectly acceptable to OSX.  
They however produce an unusable disc when burned.
As below.
Note the free space.

***********
~ me$ hdiutil pmap /dev/disk1
Partition List
## Dev_______ Type_______________ Name_____________ Start___ Size____ End_____
 0            		Apple_partition_map Apple                    		1        3        3  
-1            		Apple_ISO           	10_2_RELEASE_POWE   4       76       79  
 1            		Apple_Bootstrap     	CD Boot                		 80     6400     6479  
-1            		Apple_Free                               				 6480  1214916  1221395  
Legend
    - ... extended entry
    + ... converted entry

Type 1 partition map detected.
Block0.blockSize 0x0200
NativeBlockSize  0x0200


Options: PMEXTENDEDMODE PMSECTORIZE PMSORTMAP PMFREEGENERATE PMFREECOMBINE PMVOLSYNTH PMSKIPZEROLGH 
(-options xsSgcvk)
************


The install data required is actually present.
It is getting confused by a finishing layer of some kind of unresolvable hard/soft symlinks 

Kind regards from the South Pacific.

Marc