Bug 211615 - net/nsscache: fails to find _bsddb which is deprecated
Summary: net/nsscache: fails to find _bsddb which is deprecated
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-05 23:18 UTC by Yuri Victorovich
Modified: 2016-08-05 23:38 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2016-08-05 23:18:09 UTC
bsddb is deprecated since 2.6: https://docs.python.org/2/library/bsddb.html#module-bsddb

bsddb3 module should be used instead.


---error---
Traceback (most recent call last):
  File "/usr/local/bin/nsscache", line 28, in <module>
    from nss_cache import app
  File "/usr/local/lib/python2.7/site-packages/nss_cache/app.py", line 34, in <module>
    from nss_cache import command
  File "/usr/local/lib/python2.7/site-packages/nss_cache/command.py", line 35, in <module>
    from nss_cache.caches import cache_factory
  File "/usr/local/lib/python2.7/site-packages/nss_cache/caches/cache_factory.py", line 29, in <module>
    from nss_cache.caches import nssdb
  File "/usr/local/lib/python2.7/site-packages/nss_cache/caches/nssdb.py", line 21, in <module>
    import bsddb
  File "/usr/local/lib/python2.7/bsddb/__init__.py", line 67, in <module>
    import _bsddb
ImportError: No module named _bsddb
Comment 1 Bugzilla Automation freebsd_committer 2016-08-05 23:18:09 UTC
Maintainer informed via mail
Comment 2 Yuri Victorovich freebsd_committer 2016-08-05 23:38:31 UTC
This is actually a bug in python: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=211616