Bug 211646 - www/lighttpd: [mod_proxy,mod_scgi] shutdown remote only if local, [core] enforce wait for POLLWR after EINPROGRESS
Summary: www/lighttpd: [mod_proxy,mod_scgi] shutdown remote only if local, [core] enfo...
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-07 21:31 UTC by Piotr Kubaj
Modified: 2016-10-17 14:18 UTC (History)
0 users

See Also:
pkubaj: maintainer-feedback+
pkubaj: merge-quarterly?


Attachments
patch (5.22 KB, patch)
2016-08-07 21:31 UTC, Piotr Kubaj
pkubaj: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2016-08-07 21:31:07 UTC
Created attachment 173385 [details]
patch

There are two issues which this patch fixes (regressions in 1.4.40):
1) mod_proxy, mod_scgi may trigger POLLHUP on *BSD,Darwin: https://redmine.lighttpd.net/issues/2743
2) writev failed: Socket is not connected (fastcgi,scgi,proxy): https://redmine.lighttpd.net/issues/2744

I haven't reproduced 1) yet, but 2) has given me hard time on www/nextcloud, so we definitely want it in the ports tree :)

Build- and run-tested.
Comment 1 commit-hook freebsd_committer 2016-08-17 19:48:45 UTC
A commit references this bug:

Author: arved
Date: Wed Aug 17 19:48:29 UTC 2016
New revision: 420370
URL: https://svnweb.freebsd.org/changeset/ports/420370

Log:
  Fix two regressions:

  1) mod_proxy, mod_scgi may trigger POLLHUP on *BSD,Darwin:
  https://redmine.lighttpd.net/issues/2743
  2) writev failed: Socket is not connected (fastcgi,scgi,proxy):
  https://redmine.lighttpd.net/issues/2744

  PR:		211646
  Submitted by:	maintainer

Changes:
  head/www/lighttpd/Makefile
  head/www/lighttpd/files/patch-src_mod__fastcgi.c
  head/www/lighttpd/files/patch-src_mod__proxy.c
  head/www/lighttpd/files/patch-src_mod__scgi.c
Comment 2 Piotr Kubaj freebsd_committer 2016-08-19 12:53:23 UTC
It should also be MFH'd, since it fixes regressions.