Bug 211683 - security/clamav: Unbroke Jit engine with correct LLVM on modern FreeBSD releases
Summary: security/clamav: Unbroke Jit engine with correct LLVM on modern FreeBSD releases
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Many People
Assignee: Dima Panov
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-08-09 02:16 UTC by Dima Panov
Modified: 2016-08-10 07:27 UTC (History)
1 user (show)

See Also:
fluffy: maintainer-feedback+
fluffy: merge-quarterly+


Attachments
security/clamav: Unbroke Jit engine with correct LLVM on modern FreeBSD releases (721 bytes, patch)
2016-08-09 02:16 UTC, Dima Panov
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dima Panov freebsd_committer 2016-08-09 02:16:20 UTC
Created attachment 173432 [details]
security/clamav: Unbroke Jit engine with correct LLVM on modern FreeBSD releases

Currently LLVM engine for Jit parser in ClamAV package can use only old LLVM releases, which leads to coredumps on FreeBSD-11 at least.

Unbroke by rely on latest supported LLVM framework from ports to build Jit parser.
Comment 1 commit-hook freebsd_committer 2016-08-10 07:11:31 UTC
A commit references this bug:

Author: fluffy
Date: Wed Aug 10 07:10:31 UTC 2016
New revision: 419990
URL: https://svnweb.freebsd.org/changeset/ports/419990

Log:
  - security/clamav: Unbroke Jit engine

  Buldled LLVM is very limited/outdated and produce the broken code on recent FreeBSD releases,
  so unconditionally rely on latest supported (3.6) LLVM framework from ports to build ClamAV Jit parser

  PR:		211683
  Reported by:	many
  Submitted by:	myself
  Approved by:	garga (maintainer)
  MFH:		2016Q3

Changes:
  head/security/clamav/Makefile
Comment 2 commit-hook freebsd_committer 2016-08-10 07:16:32 UTC
A commit references this bug:

Author: fluffy
Date: Wed Aug 10 07:15:45 UTC 2016
New revision: 419991
URL: https://svnweb.freebsd.org/changeset/ports/419991

Log:
  MFH: r419990

  - security/clamav: Unbroke Jit engine

  Buldled LLVM is very limited/outdated and produce the broken code on recent FreeBSD releases,
  so unconditionally rely on latest supported (3.6) LLVM framework from ports to build ClamAV Jit parser

  PR:		211683
  Reported by:	many
  Submitted by:	myself
  Approved by:	garga (maintainer)

  Approved by:	ports-secteam (blanket)

Changes:
_U  branches/2016Q3/
  branches/2016Q3/security/clamav/Makefile
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2016-08-10 07:27:03 UTC
Assign to committer that resolved.

Thank you Dima!

Note for maintainer: I believe un-bundling using system/ports versions of libraries is the default ports policy unless doing so is broken/impossible. This would mean either defining LLVM option in OPTIONS_DEFAULT, or more clearly, changing the logic and name of the option to BUNDLED_LLVM (to make it explicit opt-in), defaulting to off.
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2016-08-10 07:27:45 UTC
Comment on attachment 173432 [details]
security/clamav: Unbroke Jit engine with correct LLVM on modern FreeBSD releases

Codify/Track the maintainer approval that was provided (on-list)