Bug 211721 - graphics/ImageMagick-nox11: now builds X11 components
Summary: graphics/ImageMagick-nox11: now builds X11 components
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Koop Mast
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-10 11:37 UTC by Gary
Modified: 2016-08-10 12:34 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (kwm)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gary 2016-08-10 11:37:07 UTC
Just tried building graphics/ImageMagick-nox11 and noticed it was going to build a slew of X11 components on a server that doesn't want/need/have X11.  Noticed that the graphics/ImageMagick Makefile now has

USE_XORG=      sm ice x11

without any conditionals around it.
Comment 1 Koop Mast freebsd_committer 2016-08-10 11:49:41 UTC
good point, I completely missed the !x11 case.
Comment 2 commit-hook freebsd_committer 2016-08-10 12:09:08 UTC
A commit references this bug:

Author: kwm
Date: Wed Aug 10 12:08:06 UTC 2016
New revision: 420009
URL: https://svnweb.freebsd.org/changeset/ports/420009

Log:
  Don't add X libraries to the nox11 ports [1]

  While here fix USE_GNOME in the SVG case to add to the USE_GNOME macro
  and not overwrite it.

  PR:		211721 [1]
  Reported by:	Gary (freebsd-bugzilla@in-addr.com)
  Pointy hat to:	kwm@

Changes:
  head/graphics/ImageMagick/Makefile
  head/graphics/ImageMagick-nox11/Makefile
  head/graphics/ImageMagick7/Makefile
  head/graphics/ImageMagick7-nox11/Makefile
Comment 3 Koop Mast freebsd_committer 2016-08-10 12:34:40 UTC
Should be fixed now, thanks for reporting!