Bug 211724 - databases/sqlite3: Update to 3.14.1
Summary: databases/sqlite3: Update to 3.14.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Pawel Pekala
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-08-10 12:25 UTC by Pavel Volkov
Modified: 2016-11-17 15:10 UTC (History)
4 users (show)

See Also:


Attachments
Update Port: databases/sqlite3 to 3.14.0 (2.63 KB, patch)
2016-08-10 12:25 UTC, Pavel Volkov
pavelivolkov: maintainer-approval+
Details | Diff
build log (17.67 KB, text/plain)
2016-08-10 12:26 UTC, Pavel Volkov
no flags Details
portlint log (22.59 KB, text/plain)
2016-08-10 12:27 UTC, Pavel Volkov
no flags Details
Update Port: databases/sqlite3 to 3.14.1 (2.56 KB, patch)
2016-08-20 07:08 UTC, Pavel Volkov
pavelivolkov: maintainer-approval+
Details | Diff
build log (18.04 KB, text/plain)
2016-08-20 07:09 UTC, Pavel Volkov
no flags Details
portlint log (22.50 KB, text/plain)
2016-08-20 07:10 UTC, Pavel Volkov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Volkov 2016-08-10 12:25:32 UTC
Created attachment 173495 [details]
Update Port: databases/sqlite3 to 3.14.0

- Update sqlite3 to version 3.14
- Added dependents from system library
- Added option SQLITE_ENABLE_UNKNOWN_SQL_FUNCTION
Comment 1 Pavel Volkov 2016-08-10 12:26:57 UTC
Created attachment 173496 [details]
build log
Comment 2 Pavel Volkov 2016-08-10 12:27:23 UTC
Created attachment 173497 [details]
portlint log
Comment 3 Yuri Victorovich freebsd_committer 2016-08-13 12:07:32 UTC
FYI There is 3.14.1 avilable: https://www.sqlite.org/releaselog/3_14_1.html
Comment 4 Pawel Pekala freebsd_committer 2016-08-14 18:54:41 UTC
Pavel: should I wait for update?
Comment 5 Yuri Victorovich freebsd_committer 2016-08-14 22:07:48 UTC
3.14.1 is a somewhat celebrated "π release", celebrated with a pie. So I guess we want that one. -)
Comment 6 Pavel Volkov 2016-08-20 07:08:49 UTC
Created attachment 173886 [details]
Update Port: databases/sqlite3 to 3.14.1

I'm sorry for the late reply. So much work.
Comment 7 Pavel Volkov 2016-08-20 07:09:42 UTC
Created attachment 173887 [details]
build log
Comment 8 Pavel Volkov 2016-08-20 07:10:32 UTC
Created attachment 173888 [details]
portlint log
Comment 9 commit-hook freebsd_committer 2016-08-23 20:27:15 UTC
A commit references this bug:

Author: pawel
Date: Tue Aug 23 20:26:25 UTC 2016
New revision: 420742
URL: https://svnweb.freebsd.org/changeset/ports/420742

Log:
  - Update to version 3.14.1
  - Add UNKNOWN_SQL option

  PR:		211724
  Submitted by:	Pavel Volkov (maintainer)

Changes:
  head/databases/sqlite3/Makefile
  head/databases/sqlite3/distinfo
Comment 10 Pawel Pekala freebsd_committer 2016-08-23 20:34:00 UTC
Committed, thanks for updated patch Pavel.
Comment 11 Jan Beich freebsd_committer 2016-11-16 17:04:07 UTC
Comment on attachment 173886 [details]
Update Port: databases/sqlite3 to 3.14.1

> +CPPFLAGS+=	${OSVERSION<1000000:?:-DHAVE_STRCHRNUL=1}

:? isn't supported by fmake on 9.x, and for 10+ it lacks extra ${...} to test value rather than the variable name. However, in the end the expression works as intended.
Comment 12 Pavel Volkov 2016-11-17 15:10:59 UTC
(In reply to Jan Beich (mail not working) from comment #11)
Hello. You're right. This does not work.
It (https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=214608) will be better this way?